: Radio Navigation Problem



RockPASTS-V
07-27-13, 08:12 PM
2006 STS-V; 50,000 miles
About three weeks ago my radio and navigation system went down. Checked fuse under rear seat. Fuse is fine. Needed new battery. New battery installed. Still no radio or navigation. I suspect this problem may be beyond my skill set. Looking for some tips or similar experiences before I make the decision to turn it over to a shop. Thanks in advance for any help.

1madstsv
07-27-13, 08:33 PM
Hit the dash on top of the nav bet it comes back on. They have issues like this.

TimmyC
07-27-13, 09:54 PM
I removed mine and unplugged it to fix it once. The car battery was bad and it had been dead for a week at least. I think that's what screwed it up.

ChurchSTSV
07-27-13, 11:51 PM
Happens to me sometimes. I snack the top of the radio and will come back on.

boomys10
07-29-13, 02:31 PM
lol at the hit the radio, if it works hit that stuff man. prolly a loose connection, take it out and replug in. might fix ya up. if it doesn't, could be fuse on back of nav (if ours has one, haven't taken that out as it hasn't broken on my car yet, lol) also could be a bad unit.

bobs-sts-v
07-29-13, 08:50 PM
Almost eight years I have had my V and NEVER had this problem (knock on burled-walnut dash).

Bob

RockPASTS-V
07-29-13, 09:59 PM
Tried the dash when I wasn't too angry. No luck. I am just north of you in Harrisburg. Thanks for responding.

1madstsv
07-29-13, 11:54 PM
Man that's like 5 Stsv in this area time to sell mine and get my blue Ctsv wagon lol.

Guy.Seminerio
07-29-13, 11:58 PM
I'm sure you remember my ctsv v2 vs stsv thread a while back and I'm also sure you've driven the ctsv but bottom line is sitting in a cts v feels like an obvious downgrade from the stsv. Although it is freakin nice and very fast.

1madstsv
07-30-13, 11:02 AM
I know that's why I have had 2 Stsv now I was just joking for now any way. But if I sell my c5 corvette for one I'm moving up. It's all in what car you are coming out of. I got rid of a v12 BMW for my Stsv and that was a steep down even on a 5 year newer car.

marshallpulham
06-10-14, 01:41 AM
sorry to revive this thread rockpasts-v but did you ever end up solving this issue mine is doing the same