: Oil Burning Eldo, 1997 Etc..



bostonscreenman
03-07-05, 01:15 PM
I have a 1997 eldo, so far my oil pump,water pump, fuel rail, all pumps struts, motor mounts...........have all blown up..

The oil burning is all I really care about...this Northstar motor really is not that
great ...unless I got the one lemon out there..oh yah head gaskets, bearings soon...aaaaaaaaaaaaaaaaaaaa!!!! what a financial burden...
HELP:(

david1549
03-07-05, 01:43 PM
I just posted this under toolmans "Oil Level" post;

http://www.cadillacforums.com/forums/images/misc/quotes/quot-top-left.gifQuote:http://www.cadillacforums.com/forums/images/misc/quotes/quot-top-right.gifhttp://www.cadillacforums.com/forums/images/misc/quotes/quot-by-left.gifOriginally Posted by bostonscreenmanhttp://www.cadillacforums.com/forums/images/misc/quotes/quot-by-right.gifhttp://www.cadillacforums.com/forums/images/misc/quotes/quot-top-right-10.gifI have a 1997 eldo ETC, it actually burns oil like a siv...my only problem has been the oxygen sensor....82000k miles

if anyone elso has a burning problem let me know...:crybaby: http://www.cadillacforums.com/forums/images/misc/quotes/quot-bot-left.gifhttp://www.cadillacforums.com/forums/images/misc/quotes/quot-bot-right.gif


I had the same problem. I've got a '96 SLS with 94,000 miles on it. I allowed my mechanic to change my oil, I had no problem with his work and left it up to him as to what brand of oil to use. It was an Exxon station and I'm sure it was the oil he made the most profit on. It used 3 quarts in 1200 miles.
I've always been a Pennzoil guy so I went to one of those quickie oil change places and had them put in 10/30 Pennzoil. I'm at 2500 miles after the change and it hasn't used a drop.
I also have an O2 sensor failing, it generates a slow response code. I just had that same one changed six months ago. Someone smarter than I would have to determine the cause and effect of high oil consumption and O2 sensor failure.

bostonscreenman
03-11-05, 11:22 AM
Pennzoil Here I Come..my Sensor Is Out As Well, The Engine Light Has Been On For A Year As Well, The Codes, When Checked Were Going Nuts, Over 30 Different Ones...but My Caddy Mechanic Say All Is Well?? Aaaaaaaaaaaa
Yah Until The Next Major Repair Job......thank You Dave For Feeling My Pain

dwight.j.carter
03-16-05, 05:49 AM
You guys ought to read up on the oil consumption on the Northstar. I read in another post that it is because of the agressive cam design and it takes more oil into the upper engine to protect those parts and mine burns oil also but I would rather it burn oil than the motor blow at 100000 for lack of oil.

growe3
03-16-05, 10:00 AM
You guys ought to read up on the oil consumption on the Northstar. I read in another post that it is because of the agressive cam design and it takes more oil into the upper engine to protect those parts and mine burns oil also but I would rather it burn oil than the motor blow at 100000 for lack of oil.

The higher than most engines oil usage, is primarily caused by a very aggressive cylinder hone pattern. Its purpose is to keep the cylinder walls well lubricated for high RPM running. Occasional WOT and using 3rd gear to decelerate will keep the rings free and keep oil usage to a minimum.

A normal oil consumption should be about 1 quart in 1200+ miles. I tend to use about 1 quart in 1500+ miles.

The stock Northstar cams are actually fairly mild. A quick way to more power is to replace the camshafts; problem is I don't think they would pass the strict emissions test.

Cadillac Hot Rod Fabricators (http://www.chrfab.com/) has some interesting parts and engine modifications for the Northstar.

-George

dwight.j.carter
03-17-05, 09:58 PM
Yeah I saw this site even before I started posting on here and I would love to take my STS down to them and rebuild the engine with an extra two hundred horse and have a 500 horsepower car. My god only in my dreams.

david1549
03-18-05, 10:00 PM
You guys that accept oil usage in a $40 or $50,000 automobile as a matter of course, well, It's, Its................Drive a Ford

Ranger
03-18-05, 10:07 PM
You guys that accept oil usage in a $40 or $50,000 automobile as a matter of course, well, It's, Its................Drive a Ford
NO THANK YOU. How many fords do you know of that have 325K on them?
http://caddyinfo.ipbhost.com/index.php?showtopic=5408w
You seem to consider oil usage a bad thing. I used to til I understood it. I've said it before and I'll say it again. Click on Technical Archive in the upper left coner and read up on oil consumption. Then you'll understand why this guy has 325K on the engine.

91TexasSeville
03-18-05, 10:21 PM
NO THANK YOU. How many fords do you know of that have 325K on them?
http://caddyinfo.ipbhost.com/index.php?showtopic=5408w
You seem to consider oil usage a bad thing. I used to til I understood it. I've said it before and I'll say it again. Click on Technical Archive in the upper left coner and read up on oil consumption. Then you'll understand why this guy has 325K on the engine.

I know of at least one, mine!