: Over heating

07-25-13, 01:22 PM
My 09 DTS II has been over heating but never running hot, the fan will come on and cool it off but today it reached hot, I didn't smell any coolant burning and there does not seem to be a coolant leak. Any ideas or known problem?

07-25-13, 04:03 PM
Check the coolant when the coolant tank cap goes bad it does not hold the pressure and it leack throught the tank.


It is easy to check when the cap goes bad the upper radiator hose is very solf you could even remove the cap when the engine is hot but not running.

07-25-13, 04:16 PM
I'll check it out and let y'all know. What esle could it be in case that's not it?

07-25-13, 04:51 PM
Also check the purg line to see if it is clog this is the line from the coolant tank to the water pump housing. To check is it easy when the car is cold disconnect the line from the tank star the car and coolant should come out of it if nothing come out disconnect it from thewater pump housing to see if coolant come out remeber you have to do thing with a cold motor

07-26-13, 02:22 PM
This morning it was down a liter of dexcool, I have a test drive booked for tomorrow and I have until Aug 23 before the powertrain warranty ends (phew). I will let you know if it is the water pump, gasket or hoses.

07-27-13, 12:22 AM
also have them pull the lower apron and look at the radiator seems mine was leaking from there but there was no sign of coolant because of the hiding spots molded on it they also did a water pump

07-27-13, 03:35 PM
Define "hot" - where was the gauge needle, and did you get the engine overheat message in the DIC ?

07-29-13, 11:42 AM
Yes the message was on the display, I topped up the overflow tank and it was down a bit, it hasn't overheated since but...I only have till Aug 23 for the powertrain warranty.