: Code P0335 on 2001 STS



01STS
03-04-05, 11:52 PM
Just driving home today and CHECK ENGINE light came on. Only code that came up it is a P0335. The car drives fine with no power loss. I know it has something to do with the crank position sensor but anyone know which one since I believe there is 2 on the 2000 and newer northstars? Any idea if I am going to do any damage driving it like this? Any insight would be appreciated.
Thanks,
Erik
01STS

LymanSS
03-06-05, 01:44 AM
Sorry, I don't have time to copy the whole description of the code, but this should start you on your way. I'll copy the rest later if you need it.

Conditions for running the DTC:

- The engine is cranking or running
- DTC p-0385 has set
- Cam faults are not present

Conditions for Setting the DTC:

- The PCM detects an intermittent loss of CKP Sensor A signal.

Sounds like it's sensor A. I'm not sure which one that is. Hope that helps somewhat.

Scott

01STS
03-06-05, 05:59 PM
Sorry, I don't have time to copy the whole description of the code, but this should start you on your way. I'll copy the rest later if you need it.

Conditions for running the DTC:

- The engine is cranking or running
- DTC p-0385 has set
- Cam faults are not present

Conditions for Setting the DTC:

- The PCM detects an intermittent loss of CKP Sensor A signal.

Sounds like it's sensor A. I'm not sure which one that is. Hope that helps somewhat.

Scott

Sensor 'A'? Thanks for your help!

Erik
01sts

LymanSS
03-06-05, 08:57 PM
I'm not sure which one sensor A is. I'll try to look it up when I get back to my house and have access to my manuals.

Scott