: Intercooler pump

07-23-13, 07:26 PM
When does the pump run? Anytime the engine is running?

07-23-13, 08:45 PM
yes. they fail all the time.

07-24-13, 02:36 AM
What are the symptoms of a failed intercooler pump? Overheating?

07-24-13, 08:21 AM
Sluggish performance due to high air temps and timing reduction.

Pull a hose off the intercooler lid while the engine is running if you think your pump is bad. If no water comes out it's not working.

07-24-13, 10:14 AM
Or you can pull the cap off the fill tube by the battery and and check for flow. There should be a good flow. When I upgraded mine I went from a trickle to a quick flow.

07-24-13, 10:42 AM

07-27-13, 03:47 PM
If its not working try unplugging it and cleaning the connection. Mine stopped working and I did that and it's still working 1 year later.

08-08-13, 11:54 PM
Disconnected hose off blower nothing came out only out of the metal line.just trying to see if ic pump is working.car runs fine but I see no movement in ic fill cap and can't hear pump running.im no mechanic .is pump covered under gmpp? Is coolant suppose to come out of hose if disconnected while car is running?

08-09-13, 04:14 AM
Yes, if you pull a line off the S/C there should be a stream of coolant come out. If there is no movement with the engine running and the cap off then yes its dead. Not sure if GMPP will cover that but it should.

08-09-13, 06:45 PM
so put the timmy c heat exchanger on mine today always wondered y my car was getting beat by cars it shouldn't well today when i went to bleed air out the chargers cooling system i commanded pump on and got nothing tapped on the pump and started working anybody know where a good aftermarket pump without having to do a lot of mods could be purchased new one from gm is 338 bucks my cost lol

08-09-13, 07:09 PM
The Jabsco is really not that hard to put in.