: power steering problems



VscharesV
07-22-13, 01:15 AM
I finished up doing a ton of bolt ons and tuning my car. Everything is perfect except my power steering is not quite right. It's like it's only half working. I unbolted it to do the cam and heads swap. I also took apart the steering shaft to get the headers in. Does anybody have any ideas what could be causing this off the top of their head, before i replace the pump. It was working fine before I tore it apart. The pulley spins freely, its full of fluid. The belts is on correctly. Any help or suggestions are appreciated.

odla
07-26-13, 12:18 AM
Air in the line?

VscharesV
07-26-13, 03:30 AM
I never opened the system. But I tried the method to self bleed, with no luck on the results.

RyRidesMotoX
07-26-13, 05:04 AM
I'm subd to this one... I have had a weird steering issue also. Right after I start the car, if I come to a right hand corner it feels like there is something almost "dragging" or something. But it only does it on the first right hand turn. After that its good until I start it up again. There is no whine or anything from then power steering pump or anything. I'm probably going to top it off anyways since the reservoir seems about 1/2 full. I dunno just seems odd it won't do it on lefts also.

OP-Is that anything like you are getting?

VscharesV
07-27-13, 08:17 AM
Mine is constant. You know how the power steering help decreases as speed increases. Well my steering feels like I'm going 110mph all of the time. I am seriously stumped. The steering shaft does rub just a tab on the header but this feels harder that just a little rub.