: Throttle position sensor



Psycho-albanian
07-15-13, 02:15 PM
Anyone ever had one go bad on them? I went to go start my car and the car wouldnt start so I hooked upmy scanner and it gave me a throttle code. Cleared the code and it started right up.

boomys10
07-15-13, 06:34 PM
I thought I did. what mods do you have?

----------

it could easily be a loose connection after the maf also. this DOES like tps is bad, you have to replace the entire tb if so. not that bad of a process, ive done mine 5times at this point. lol

Psycho-albanian
07-15-13, 06:50 PM
Tim c 2.4 pulley, throttle body, headers, d3 stage 1&2 intake,borla exhaust and tim c heat exchanger.

boomys10
07-15-13, 07:01 PM
I would start be checking all connections on your intake INCLUDING the y piece that connects to the throttle body. if those are all tight, then its the tb. not a bad change if that's the case, I have found out the hard way you can get them from rockauto for like 70$ shipped. after paying WAY more the first time.

Psycho-albanian
07-15-13, 07:21 PM
70 for the sensor is not bad at all. I just want to get rid of this damn po175 po172 code that has haunted me for a year and a half. I've changed everything from 02 sensors, maf sensors, fuel filter, thermostat and I still get these 2 rich codes.

boomys10
07-15-13, 07:28 PM
I don't know what the codes are off hand man. I just know the tps code I had WAS NOT either of those.

Psycho-albanian
07-15-13, 07:48 PM
I was told that a bad throttle position sensor could cause the po172 and po175 code.

boomys10
07-15-13, 07:52 PM
have u looked in the cats? that might be clogged that could cause it. the tb is a cheap replacement, not saying its a bad idea, just saying I don't know if that will fix the problem

Psycho-albanian
07-15-13, 07:57 PM
I'm running catless.

boomys10
07-15-13, 07:59 PM
have you been retuned for catless?

TimmyC
07-15-13, 08:11 PM
I was told that a bad throttle position sensor could cause the po172 and po175 code.

Who told you that? Those are rich codes because you have 60s without the right tune.

What was the number of the code you had this morning?

I haven't heard of the position sensor inside the throttle body going bad yet. It seems like boomy might be right on the cause of his code being a post-maf air leak. Better check that out.

Psycho-albanian
07-15-13, 08:35 PM
Jesse tuned for 60 lb injectors and no cats and tim c 2.5 pulley But that was before I added the headers and the 2.4 pulley.

TimmyC
07-15-13, 08:44 PM
I remember when it was here it was running really rich. I took some fuel out of it but we didn't do any tuning per say. A better tune will fix the 0172 and 0175 problem.

Psycho-albanian
07-15-13, 08:54 PM
Im thinking about ditching my d3 intake for your intake timmy how much does your intake cost?

TimmyC
07-15-13, 08:56 PM
Im thinking about ditching my d3 intake for your intake timmy how much does your intake cost?

$399

Psycho-albanian
07-15-13, 09:20 PM
Do you only take pay-pal ?

TimmyC
07-16-13, 12:10 AM
Or money order.

Psycho-albanian
07-16-13, 09:26 AM
Address?

boomys10
07-16-13, 10:47 AM
you will need another tune psycho, buying his intake will not get around that.

Psycho-albanian
07-16-13, 12:58 PM
Yeah I know.

----------

Tim what's your website so I can order the intake.

boomys10
07-16-13, 01:58 PM
if I might make a suggestion. fix the issues at hand before adding something that could cause more. changing parts right now isn't the best idea if your alrdy having problems. fix it now, then add later. I had to wait months to resolve some issues with mine before moving forward with the build. no point in compounding problems.

rbzstsv
07-16-13, 03:53 PM
I couldn't agree more. One step at a time. I bought hptuners weeks ago. Im still waiting on hptuners to release new vin/OS pairings.

Psycho-albanian
07-16-13, 06:57 PM
Boomy im trying to fix the problem I just cant pinpoint whats causing it. I've done everything from new fuel filter/ regulator, new maf, new thermostat everthing that could cause my rich codes.

----------

I think I found the leak like boomy said right at the clamp that hooks the stage one and two intake together I sprayed some soap water around the coupler and the idle changed big time like it wanted to stall out.

boomys10
07-16-13, 07:11 PM
any more progress on it buddy? make sure after you do whatever to fix it you reset the battery or clear the codes. they wont normally go away on their own from my expirences.

Psycho-albanian
07-16-13, 07:17 PM
Im just gonna ditch the d3 intake cause it gets so hot and tims looks and sounds better and flows better.

TimmyC
07-16-13, 07:22 PM
Im just gonna ditch the d3 intake cause it gets so hot and tims looks and sounds better and flows better.

Good choice ;)

Codes will eventually go away once the problem is fixed but it takes a long time. 50-100 start cycles sometimes.

Psycho-albanian
07-16-13, 07:52 PM
Tim how can I order your intake do you have a website?

TimmyC
07-16-13, 07:59 PM
I just PM'd you my address. No website at this point. Everybody just PMs me or uses email.