: 2007 Escalade rear suspension change



racingdc9
07-11-13, 12:06 AM
I recently got the "service suspension system" code. I've read on here that usually that message means, the air pump is bad but my air pump still kicks on. I did see that the both rear shocks were leaking so I ordered Arnott's bilstein replacements and had them installed today. Well, the "service suspension system" code still comes on. I still hear the air pump kick on when I turn the key to the on position but the code still comes on. I've also read that the code may go away after a few cycles but how many? Or is the air pump bad even though it's still kicks on?


Tommy

Cadillac Cust Svc
07-11-13, 05:43 PM
Hello Tommy,

I apologize that you are experiencing a “service suspension system” code on your Escalade. I also see that you are reaching out to the community for some answers to your questions. I just wanted to let you know that if you were still concerned about the code, and were willing to take your vehicle into the dealership, I would like to assist you in working with them. Please private message me if this is the route you would like to pursue. Thank you very much for taking the time to read my post.

Gregory W.
Cadillac Customer Care

hcvone
07-12-13, 04:52 PM
You could also disconnect the battery for 15 minutes, just make sure you turn off the sound system and HVAC, that will clear them too

racingdc9
07-13-13, 11:58 PM
Thanks, i'll try that.

racingdc9
07-17-13, 12:54 AM
Well, disconnected the battery for 15 min and still didn't do the job. But now, sometimes the air compressor doesn't come on during the testing phase, and sometimes it does. Maybe the compressor is going bad but not fully dead yet?

blackex
07-17-13, 09:25 AM
That could definitely be the case. It should come on everytime for a few seconds.

mooksta12
08-20-13, 10:08 PM
I'm having the same problem.. Can some1 please help me?? My service suspension light is on .. But I hear the compressor kick on..

Ran-Dom32
08-21-13, 02:34 PM
There is a body control module under the rear spare tire, this controls & sends signals to the compressor , this is most likely your problem, I went through this a few months ago, changed out the compressor, shocks & finally the BCM .. no more codes