: Oxy Sensor Not Talking



libbysman
07-07-13, 02:07 PM
Hello All: My 97 Cat is idling rough, so I hooked up an OBDII code reader to see what was happening. I had one code (P0140) indicating no activity at Bank 1, Sensor 2. I had replaced it about 2 years ago. Anyhow, I put in a new one but still have the code. I erased the code and re-ran the test, but its still coming up. Anyone have any idea where to go next? All help would be appreciated Cheers, Brian

MoistCabbage
07-07-13, 06:36 PM
Have you inspected/tested the connector and wiring?

What brand is the replacement?

libbysman
07-08-13, 04:54 PM
Hello M.C. I haven't checked the wiring from the initial socket near the trans. I guess I'll have to try to trace it back to the ECM. The replacement sensor is a Bosch unit. I noticed the unit I removed was quite carboned up, but that is most likley as a result of the lack of input from this sensor. Regards, Brian

libbysman
07-09-13, 11:12 PM
M.C. and other interested parties: How would I test the circuit? I have a multimeter, not too sure how to use
it though lol. Does the harness that the sensor plugs into go directly to the ECM or might there be another
socket before? I drove to work today and it didn't idle roughly until I was halfway there, approx. 12 km. It did
likewise coming home. Does it take that long to heat up? Regards, Brian

MoistCabbage
07-10-13, 02:06 AM
Without specific testing procedures from the FSM, start by testing each wire for continuity. I'm not sure in the Catera, but would assume that the harness leads directly to the PCM.

A rough idle has nothing to do with the O2 sensor.

marko69
07-10-13, 04:06 AM
Just to make sure, I would swap the sensor with the one on the other side and see if the trouble follows.
Also try cleaning the connector with some contact cleaner or alcohol and see if that helps.

libbysman
07-10-13, 02:39 PM
MC: Does the oxy sensor not tell the ECM the oxy content of the exhaust for it to determine the correct fuel mixture and volume. Maybe I'm giving the ECM too much credit for what it does, but it seems logical.

marko69: I agree, cleaning the conacts wouldn't hurt. I have spray contact cleaner and I'll give it a good dose. If I swap the sensors right to left at least I will get a different code. I should add that I didn't get a check engine light at all.

I'm also thinking that maybe it could be a vacuum leak. Maybe? Regards, Brian

marko69
07-10-13, 08:13 PM
Here is some info from my (2001) manual that may help you find the problem. One thing to point out is that the check engine light will only come on if the diag runs and fails after 2 engine cycles and will clear if it passes after 3 engines cycles. (don't know if it is the same for a '97)

DTC P0140 or P0160
Circuit Description
The heated oxygen sensor (HO2S) produces a voltage that varies between 100-900 mV during normal operating conditions. The engine control module (ECM) produces a bias voltage on the HO2S signal circuit of 420-480 mV. The reference ground for the sensor is provided through the ECM. The ECM monitors the signal voltage to determine if the exhaust is lean or rich. The oxygen sensor voltage is high when the exhaust is rich, and low when the exhaust is lean. The ECM constantly monitors the HO2S signal during the Closed Loop operation.

Conditions for Running the DTC
The engine is running.
The battery voltage is more than 11 volts.
Conditions for Setting the DTC
The HO2S voltage is between 401-519 mV.
The above conditions are met for more than 60 seconds.
Action Taken When the DTC Sets
The control module illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
The control module records the operating conditions at the time the diagnostic fails. The first time the diagnostic fails, the control module stores this information in the Failure Records. If the diagnostic reports a failure on the second consecutive ignition cycle, the control module records the operating conditions at the time of the failure. The control module writes the operating conditions to the Freeze Frame and updates the Failure Records.
Conditions for Clearing the MIL/DTC
The control module turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail.
A current DTC, Last Test Failed, clears when the diagnostic runs and passes.
A history DTC clears after 40 consecutive warm-up cycles, if no failures are reported by this or any other emission related diagnostic.
Clear the MIL and the DTC with a scan tool.
Diagnostic Aids
Use the J 35616-A Connector Test Adapter Kit for any test that requires probing the ECM harness connector or a component harness connector.

If the conditions to set this diagnostic trouble code (DTC) are not present, check for the following conditions:

Heated oxygen sensor wiring--Check for the following conditions:
A signal wire intermittently open or with excessive circuit resistance
A reference ground wire intermittently open, shorted to ground, or with excessive circuit resistance
The sensor pigtail or the harness may be mis-positioned and contacting the exhaust system.
An oxygen supply inside of the HO2S is necessary for a proper operation. This supply of oxygen is provided through the HO2S wires. All of the HO2S wires and connections should be inspected for breaks or contamination. If any wiring requires repair, refer to Wiring Repairs in Wiring Systems.
Inspect the connectors for the following conditions:
Proper mating
Broken locks
Improperly formed or damaged terminals
Corrosion and water intrusion
A contaminated HO2S--Contamination can include the following:
Fuel contamination
Use of incorrect RTV sealant
Excessive oil or coolant consumption
Exhaust leaks--An exhaust leak may cause the outside air to be pulled into the exhaust gas stream past the HO2S, causing this DTC to set. Check for any exhaust leaks near the HO2S.
Improperly torqued HO2S
Inoperative HO2S heater
Poor ECM grounds
Test Description
The numbers below refer to the step numbers on the diagnostic table.

The engine must be at the normal operating temperature before performing this test.

Using the Freeze Frame data may aid in locating an intermittent condition. If the DTC cannot be duplicated, review the information in the Freeze Frame. Try to operate the vehicle within the same Freeze Frame conditions, the RPM, the mass air flow (MAF), the vehicle speed, the temperature etc., that were noted. This process may help in order to recreate the condition that set the DTC.

The ECM provides the reference ground for the oxygen sensor. A small amount of current will appear on this circuit when the ECM is operational. The measured resistance of the circuit will increase when the ECM is operational. This is considered normal.

The ECM provides the reference ground for the oxygen sensor. A short to ground on this circuit will cause the signal voltage to shift.

An oxygen supply inside the HO2S is necessary for proper operation. This supply of oxygen is provided through the HO2S wires. Inspect all HO2S wires and connections for any breaks or contamination.

Perform the Idle Learn Procedure when replacing the ECM or the throttle body.

MoistCabbage
07-10-13, 08:19 PM
MC: Does the oxy sensor not tell the ECM the oxy content of the exhaust for it to determine the correct fuel mixture and volume.It does, but that job falls mainly to the MAF sensor. Also, when a sensor sets a code, while it is current, the sensor is ignored, and the PCM uses preset values, and/or input from other sensors so the engine can continue to function.

Idle/running problems with no codes, is usually ignition or fuel related.

libbysman
07-12-13, 02:53 PM
Hi Marko69: Thank you for your efforts. You've given me a lot to consider. Looks like I've got myself a job for Saturday. I think all those procedures would be correct for all Cats.
M.C.: You're right the MAF is in charge of fuel ratios, flows etc. Thanks for reminding me of that.

You guys have saved me from a day at the mall with the better half. lol Thanks again, and wish me luck. Regards, Brian

libbysman
07-23-13, 02:28 PM
Hello MC and All: Well, you are right about the rough idle not being related to the sensor (maybe). I pulled the plug wires for a couple of cylinders on bank 1, and to my shagrin I found lots of oil. What really ticks me about that is that one of the last jobs I had done by my garage was to replace all the valve cover gaskets. They went out of business 2 months later. damn I haven't had time to further address the sensor situation, but will get to it soon.
So, now I've got to suck all that oil out of the plug wells and consider what I can do about the leakage. Money is tight right now, so I 'll have to come up with something. Regards, Brian

MoistCabbage
07-23-13, 02:34 PM
Oil is an electrical insulator, it won't cause a misfire. If they're original, it's time for plugs and wires.

libbysman
07-25-13, 05:26 PM
Hello MC: I changed the wires (Bosch) and MGK iridiom (?) plugs about 3 years ago. Well, maybe it's not misfiring, maybe there is a non-fire, which would not be applicable to set a code as there wouldn't be a plug charge going to ground. That would explain not getting a misfire code. I've read something about an idle sensor or something like that. Would you know anything about that. The engine feels like its running on 5 cylinders at idle, enough to make the exhaust system rattle. It's a pain in the a... Any thoughts? Regards, Brian