: Service engine soon light-94 concours



frontierman
02-21-05, 01:07 PM
My "service engine soon" light keeps coming on..I pulled the codes by pushing the off and warmer on the hvac controls..here is what I got..I need some help.
Here are the codes:
code po 13 history
code po 44 history
no ipc codes
noacp
no sir
notcs
so21 history
so 60 history
pcm?

That is all I got..Can you help?

Ranger
02-21-05, 05:36 PM
P013 (E013) .......................................... Right Oxygen Sensor Not Ready
P044 (E044) ........................................ Right Oxygen Sensor Signal Lean
S021 .......................... Left Rear Damper Solenoid Valve Short to Ground/Open
S060 .............................................. Left Front Position Sensor Fault

PCM? is asking if you want to enter the PCM mode.

All your codes are history. The SES light will come on when the fault is detected and the code will be "current". If after 3 ignition cycles, the fault is not detected the code will go to "history". So it sounds like your o2 sensor is intermittent.

You can find more info here. http://myweb.accessus.net/~090/dtcobd1.html (http://myweb.accessus.net/%7E090/dtcobd1.html)

frontierman
02-21-05, 05:43 PM
How are each of these problems cured? Thanks

mcowden
02-21-05, 06:41 PM
Sounds like it needs a new O2 sensor, and that will cure two codes, the the left rear shock might be going bad if the damper is shorted out. The left front position sensor could be disconnected or bad or the link is disconnected. Take the tire off and you should see it behind the rotor with a small metal link connected to the arm. If the link is off, put it back on there. If the wire is disconnected, reconnect it. If all looks well, the sensor may need to be replaced. There are several possibilities here. Are you planning to do the work yourself or take it somewhere?

frontierman
02-21-05, 09:09 PM
I will take it somewhere

mcowden
02-21-05, 11:23 PM
So, if you take it somewhere to get it done, they should replace an O2 sensor. Parts and labor on that shouldn't exceed about $150-$200, but you can do it yourself for about $65-$75. I don't know how much the shocks cost, but I do know they are expensive. The oxygen sensor is what causes the SES light to come on. The other codes are not related to SES at all, but you might get a "Service Ride Control" message on the DIC. The left front position sensor and the left rear shock would probably both have to be replaced to make that go away. Some people have replaced their shocks with standard, non-electronic models that are much, much cheaper. They work fine, and there are ways to prevent codes from being generated by the lack of electronic shocks. If you search the forums, you will probably find what you need here.

Fixing the oxygen sensor will probably increase your fuel mileage and performance as well as make the light go away. Let us know what you decide to do and how it turns out.