: Jabsco pump Install



rbzstsv
07-03-13, 10:55 PM
Taking a short break figured i would post a few pictures so far Fairly straight forward so far. Took me about 30 to 45 minutes to get stock pump out. Now I'm cutting the old pump bracket and fitting jabsco pump to that bracket. I'll post more pictures in little bit

AriGold.
07-03-13, 11:11 PM
Nice job! Did you add any extra support on the factory bracket for the new pump? Jamie (PGA) had told me the factory groumet may end up breaking over time. The new pump is heaver so I added some support.

http://www.flickr.com/photos/bobbynot/9087529692/

PGA2B
07-04-13, 08:47 AM
I think it was not a support issue but a dry rot issue on the part of the Jabsco grommet.

todrules
07-04-13, 12:46 PM
My question would be why would you be using a Sharkbite fitting? Those are specifically barbed ends for PEX. I would honestly recommend a standard male pipe X hose barb type. The barbs for PEX are made to be crimped, not for hose clamps.

rbzstsv
07-04-13, 03:04 PM
I didn't realize that. I went to the local home depot, told the guy what I was trying to do. I brought the pump in with me for reference. He said this is what I was looking for... I'll be making another trip to home depot tomorrow for some different ones.

AriGold.
07-04-13, 04:56 PM
I think it was not a support issue but a dry rot issue on the part of the Jabsco grommet.

I say breaking, What I meant was rot like Jamie said. That's why I added the extra nut and bolt.

Fierofiend
07-05-13, 09:03 AM
I wouldn't worry about that fitting, not worth the hassle of rebleeding the IC.

Fierofiend
07-17-13, 06:20 PM
Did you finish up the install? Any more pictures?

rbzstsv
07-17-13, 08:30 PM
Yes installed finished. I'll post more up this weekend when I'm back in town.

Fierofiend
07-21-13, 04:19 PM
I did a bit more work on mine today. Here are two pics showing the bolts that need to be removed so that the impeller housing can be rotated. I was a bit unsure how that worked, but once I removed the two screws, i realized there is another set of holes 90* apart. I either missed that detail, or no one was really too clear on it. I just wanted to point it out for others that may reference this.

http://i13.photobucket.com/albums/a260/Fierofiend/Mobile%20Uploads/a644511f-8007-40c0-a087-23aca249a212_zpse31ce249.jpg

http://i13.photobucket.com/albums/a260/Fierofiend/Mobile%20Uploads/5f8a9f2d-bab8-4b6e-b134-61647af1e923_zps73386fab.jpg

Also, be careful removing the screws that hold the bracket on. I had one get caught inside the frame and it was a real pita trying to fish that thing out of there.

Fierofiend
08-03-13, 09:35 PM
Well I guess I screwed up those links. I'd fix them, but I can't edit. Here are more pics of my install...

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/a644511f-8007-40c0-a087-23aca249a212_zpse31ce249.jpg

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/5f8a9f2d-bab8-4b6e-b134-61647af1e923_zps73386fab.jpg

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/IMG_20130803_211334_zpsaafc4594.jpg

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/IMG_20130803_211902_zps87596202.jpg

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/IMG_20130803_211958_zps979d08e7.jpg

47 Che V
08-08-13, 10:52 PM
Inner cooler tubing and hose size must be of what size and capisity (volume) to properly cool super charger.

rbzstsv
08-09-13, 08:32 AM
I reused stock hoses

Fierofiend
08-28-13, 09:47 PM
I also reused stock hoses. The way I mounted my pump it was really close to the power steering cooler line and also the IC hard line. The picture makes it look closer than it is, but something to keep an eye out for.

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/IMG_20130825_210836_zpscaa25f4d.jpg

http://i13.photobucket.com/albums/a260/Fierofiend/STS-V/IMG_20130825_131300_zps796aedb3.jpg