: Sign you might need a new waterpump..



Poda
06-29-13, 10:32 PM
After doing my waterpump last week (noticed a small puddle about the size of a quarter walking back to the car in a grocery parking lot 5 mins from home, popped the hood and it was steaming from the weep hole), I just put the old one aside and forgot about it.

Well, today I was cleaning up the garage, and before boxing it up to keep as a potential core later on (I have the room, so meh.. why not), I thought I'd take a closer look. I found this.. Missing cover, bearings and all.. Certainly explains some of the high pitch grinding sounds I was hearing a couple of weeks before but that had suddenly stopped. I pulled the front cover off, and the shaft is now so loose the impeller was hitting the sidewalls.

121513

Yeah, it's a miracle it didn't grenade on me - I certainly didn't have much time left on it and I lucked out on this one. The Cadillac Gods are smiling on me, considering I have an hour long commute to work each way.

jayoldschool
06-29-13, 10:35 PM
My SS pump looked the exact same. It was leaking when I bought it, and I drove it for another couple of years before the seal finally blew out with a shower of coolant. Still on the same opti.

cadillac kevin
06-30-13, 02:26 AM
Ummm....aren't the bearings and cover in the cooling system inside the engine (they had to go somewhere)?

j2rossit
06-30-13, 10:35 AM
Wow, looks like one or two balls away from seizing. Lucky break.

jayoldschool
06-30-13, 12:43 PM
kevin, when it gets this bad, the pieces of the seal and bearings comes out the back, and falls on the ground.

Cadillacboy
06-30-13, 03:34 PM
We had ours replaced years ago too and I believe it was not that bad as you showed in the pic lol . It's not worth taking the risk considering it's just perched above the distributor I believe and when it starts seepage things are not promising lol