: Waterpump replacement - after the fact question



Poda
06-24-13, 01:29 PM
I was lucky enough this weekend to notice coolant just starting to seep from the weep hole. After figuring out that I had days if I'm lucky, or hours if I'm not, I parked the car and got to work getting parts and getting it done.

Not too bad, and now that I've done one the next one will be a lot quicker when it comes off again in a couple of months for the heads and opti swap.

This morning, I noticed a little puddle of coolant. Doh.. It turns out it's seeping from the heater core hoses at the pump. They're clamped on tight, but still seeping. Do the hoses need to be over both barbs on the metal tubes? Or just butt up against the second? Is there a trick to get these to stop leaking, at least until I get around to replacing them (which ideally, would be when the head/opti swap happens) - I was thinking a second set of clamps..

csbuckn
06-24-13, 04:20 PM
Another clamp may work but, if the hose is cracked near the end, you may not get it to stop leaking. Cracks and pinholes can be hard to see.

bigm57ict
06-24-13, 04:21 PM
It's very likely the hose is ready for replacement. They get old and stiff. It continues to seal well until you disturb it. Then it is done.

jayoldschool
06-24-13, 06:43 PM
The hose goes over both ridges. The clamp goes between the ridges.

Poda
06-24-13, 08:44 PM
Thanks guys - I put a second clamp on and so far so good. Will be sourcing new hoses for this weekend, and install them if the weather holds up.

jayoldschool
06-24-13, 09:17 PM
I wouldn't be so quick to replace the hoses. The materials are very good. I have actually never heard of someone losing an LT1 hose. Doesn't mean that it hasn't happened yet, but that's in 15 years of me driving them and reading more posts than can count on the various forums...

Poda
06-24-13, 09:43 PM
Fair enough.. I'll keep an eye on it over the next week or so. I did notice how pliable they still were though. Thanks for the tip Jay!