: Suspension



acecody
02-10-05, 10:37 AM
My Catera has 100,300 miles on it and I want to know if anyone else has this same problem, or if it is even a problem. It seems as though the front end of the car has a very stiff ride. Over smaller things like bumps and bridge separators it feels like a "wham", but it rides smooth over bigger bumps. Also it seems like I feel too much of the road through the car. Do I need new struts? Is it time to change them? I really don't know if this will make much of a difference. Please all respond back and if you have any recomendations on aftermarket struts let me know, I want a smoother quieter ride, but try to maintain the sportiness. Thanks guys.

AllenPacla
02-10-05, 07:48 PM
I noticed the same problem with my Catera the first time I got it. And the thing that is more surprising is it's even worse when you are driving really slow like getting into a parking area or slowly running over a manhole. Then i decided to check my tire pressure and get it to the recommended level. By the way, I did a change of the strut long before and the problem persisted. Going back, after i got the tire pressure back to 32, the problem seems to have disappeared. Now, i only hear the thug sound whenever it's really a deep hole and I am running at a normal speed. Unlike before where i am running like a turtle and it would still make that sound, sounds like something just got disconnected in the whole suspension assembly in the front. And I don't know if it also is the same case with you, it's more prevalent on the right side in my car than on the left.

97Catera
02-10-05, 09:19 PM
bring the car to a shop or if your good check the ball joints yourself,thats what it sounds like to me.