: 06 3.6 rattling noise 5 seconds after startup almost stalls



repnatl
06-20-13, 08:34 PM
Trying to pinpoint this issue while I still have the truck. Its only on a first startup regardless of temperature. After starting runs fine then after a 5 second idle it starts to have a horrible rattling/knocking sound in the motor and almost dies then its great the rest of the day. No dtcs or driveability issues just the startup any ideas. 102k miles had severe previous sludge cleaned all of it out and timing chains at 84k miles this just started at 100k miles.

Cadillac Cust Svc
06-20-13, 10:56 PM
Trying to pinpoint this issue while I still have the truck. Its only on a first startup regardless of temperature. After starting runs fine then after a 5 second idle it starts to have a horrible rattling/knocking sound in the motor and almost dies then its great the rest of the day. No dtcs or driveability issues just the startup any ideas. 102k miles had severe previous sludge cleaned all of it out and timing chains at 84k miles this just started at 100k miles.
Hello repnatl,

I apologize that you are experiencing a rattling noise every time you start your SRX. I see that you are reaching out to the community to see if they have any ideas about your concern. If you are interested in taking your vehicle to the dealership I would like to assist you in working with them. Please private message me if that is the route you would like to take. Thank you very much for your time.

Gregory W.
Cadillac Customer Care

wholegrain
08-23-14, 09:22 AM
I have this same issue on my 2006 CTS. So far I haven't been able to figure out the cause. Have you found the issue on yours yet? Thanks.


Trying to pinpoint this issue while I still have the truck. Its only on a first startup regardless of temperature. After starting runs fine then after a 5 second idle it starts to have a horrible rattling/knocking sound in the motor and almost dies then its great the rest of the day. No dtcs or driveability issues just the startup any ideas. 102k miles had severe previous sludge cleaned all of it out and timing chains at 84k miles this just started at 100k miles.