: Rough idle - 2011 cts4 coupe



Egrasso58
06-20-13, 02:55 PM
Hey everyone,

I just purchased a 2011 cts 4 with a 3.6 in it. It has just over 22k miles on it. I got the car about 2 months ago from a used car dealership and since the day I bought it I noticed it runs rough at startup, while idling or when I have it in D and the brake applied. Other than that, and a broken driver side sun visor, (which if anyone is selling one or knows where to buy a black one I would be interested) the car is in perfect condition. I've read other posts in the forum to check out what it could be but there are a bunch of different things that were said. One thing I noticed, is that the lower octane gas I used, the better it ran, if that makes sense. I am scheduled to bring it to a cadillac dealership on Tuesday to get the injectors cleaned as per their suggestion. Does anyone on here think that could be it, or could it be something more serious? I appreciate any help or opinions I can get on this!

Thanks!
Eric

Thanks!
Eric


Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

Cadillac Cust Svc
06-20-13, 06:03 PM
Hey everyone,

I just purchased a 2011 cts 4 with a 3.6 in it. It has just over 22k miles on it. I got the car about 2 months ago from a used car dealership and since the day I bought it I noticed it runs rough at startup, while idling or when I have it in D and the brake applied. Other than that, and a broken driver side sun visor, (which if anyone is selling one or knows where to buy a black one I would be interested) the car is in perfect condition. I've read other posts in the forum to check out what it could be but there are a bunch of different things that were said. One thing I noticed, is that the lower octane gas I used, the better it ran, if that makes sense. I am scheduled to bring it to a cadillac dealership on Tuesday to get the injectors cleaned as per their suggestion. Does anyone on here think that could be it, or could it be something more serious? I appreciate any help or opinions I can get on this!

Thanks!
Eric

Thanks!
Eric


Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

Hello Eric,

Congratulations on your new CTS! I apologize that you are experiencing an issue with your vehicle running rough. I see that you are taking it into the dealership on Tuesday to get the injectors cleaned. Please keep us updated on how that visit goes on Tuesday. Thank you very much for your time and I hope that will fix the issue that you are experiencing.

Gregory W.
Cadillac Customer Care

Egrasso58
06-29-13, 01:18 AM
So I picked up my car today and they said there are no problems and no codes. They tested the fuel and said that is fine too. Unfortunately the car still runs rough, especially at start up for the first minute or so where it will shake very badly. I may take it to another dealer for another opinion since I feel the car shouldn't run the way it does.


Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

C "T" ess
06-29-13, 09:42 AM
There have been many posts over the last several months attesting to the fact that mechanics are no longer mechanics. To repair todays cars almost requires a degree in computer science. I think in certain cases; if it doesn't throw a code then the car is fine. Every once in a while you will meet a mechanic who can think outside the box and can get to the cause of the problem. (as my doctor says, they no longer practice medicine, they practice avoiding malpractice).
If the gas is good and the fuel pump checks out ok, then it has to be in the engine management area. This usually means bad plugs, coil pack and injectors. With 22k miles you wouldn't generally suspect one of those areas but the rough idle usually indicates a mechanical rather than electrical problem. Hopefully the second dealer will have someone who is able to isolate the problem and fix it.

Cadillac Cust Svc
07-01-13, 11:24 AM
So I picked up my car today and they said there are no problems and no codes. They tested the fuel and said that is fine too. Unfortunately the car still runs rough, especially at start up for the first minute or so where it will shake very badly. I may take it to another dealer for another opinion since I feel the car shouldn't run the way it does.


Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

Hello Egrasso58,

I apologize for any vehicle issues you are experiencing. I see you have taken it to a dealer already to be diagnosed and they were unable to find any codes. You mentioned taking your vehicle into another dealer for a second opinion; are you still thinking about this option? If you would like to further discuss your concerns, please private message me.

Laura M.
Cadillac Customer Service

Egrasso58
07-08-13, 01:03 PM
I appreciate the help so far! At this time I am not going to bring it for a 2nd opinion. I am going to try to reset the ETC, which according to the manual seems simple enough, and other posts in this forum suggested that's a good place to start as it fixes some rough idles.


Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

zen
07-08-13, 02:04 PM
" I noticed it runs rough at startup, while idling or when I have it in D and the brake applied. "

Could be a small Vacuum Leak.

Egrasso58
07-16-13, 10:08 AM
So I took the battery out to reset the throttle control. The car overall seems to be running a little better and seems more responsive, which leads me to believe the used car dealership I bought the car from disconnected the battery at one point and did not do a proper relearn. Unfortunately the rough idle is still present. And I noticed it gets noticeably worse if I turn the car off, run a quick errand and turn the car back on like 5-10 minutes later. I'm going to bring it to another Cadillac dealership and have them check out the mechanical components you guys have suggested that could be the problem. I appreciate the help and advice!

Cadillac Cust Svc
07-16-13, 04:07 PM
So I took the battery out to reset the throttle control. The car overall seems to be running a little better and seems more responsive, which leads me to believe the used car dealership I bought the car from disconnected the battery at one point and did not do a proper relearn. Unfortunately the rough idle is still present. And I noticed it gets noticeably worse if I turn the car off, run a quick errand and turn the car back on like 5-10 minutes later. I'm going to bring it to another Cadillac dealership and have them check out the mechanical components you guys have suggested that could be the problem. I appreciate the help and advice!

Hello Egrasso58,

I see you are taking your vehicle in to another dealership. I understand how the vehicle rough idle issue can be frustrating to deal with. Please let us know how things go after your next dealer visit. You know how to get a hold of us via private message as well.

Sincerely,

Laura M.
Cadillac Customer Care