06-19-13, 11:32 PM
I tried the search button but there doesn't seem to be anything specific about the STS-V and the issues I'm having. Sorry in advance for the long post, just trying to be as descriptive as possible.

It started yesterday when I was driving to work (2006 STS-V, with 84k miles, new ACDelco battery in February) the A/C turned off, the radio went silent, and I got the warning on the DIC that the battery voltage was too high. After that warning the power steering went out, and I got the check AIBAG SYS, STABILITY SYS, CHECK BRAKE SYS, etc. I pulled over and thought that turning the ignition off and on might somehow reset the system... I was wrong. I put the car in park and off I went and the car would not shift through any of the gears, in automatic or manual, and then I got the message BATTERY NOT CHARGING, SERVICE CHARGING SYS, BATTERY LOW VOLTS, BATTERY SAVER ACTIVE, once I got to work (taking side roads since the car wouldn't shift and was in 3rd or 4th), I put the car in park and turned it off, I got the SHIFT TO P message. Fired it back up, turned it back off, same thing. So I disconnected the battery and started trying to find some info.

I went to Autozone after work and had them test my battery, it was at 66% and needed a charge. Once it was charged both the battery and alternator passed the test, however I still had the warnings: BATTERY NOT CHARGING, SERVICE CHARGING SYS, BATTERY LOW VOLTS, BATTERY SAVER ACTIVE. So I decided to call it a night and go to Cadillac the next morning. After a full diagnostic they said it was the alternator and wanted to charge me an arm and a leg to install it, without garauntee that it was the remedy. I purchased a remanucatured alternator from Pep Boys, and had it installed by a friend. When I started the car I got a volt reading of 14.5 and it seemed as if the problem was solved. Not a block down the road I get the same warnings: BATTERY NOT CHARGING, SERVICE CHARGING SYS, BATTERY LOW VOLTS, BATTERY SAVER ACTIVE. At this point I tried the old trick of turning the car on, and disconnecting the battery to see if it would contine to run. Once I disconnected the terminal it immediately shut off. Is this the alternator? Or is there an override in the system that cuts the motor when the battery is disconnected? My last resort was to replace the battery and even with the new battery I am still getting the same errors: BATTERY NOT CHARGING, SERVICE CHARGING SYS, BATTERY LOW VOLTS, BATTERY SAVER ACTIVE.

I know it was a book, but I tried to include everything in hopes that one of those details would stick out to someone and perhaps suggest a solution or past experience that solved this issue.

06-20-13, 12:32 AM
There should be a cable that foes directly to the battery from the alternator, make sure it hasn't come loose or corroded away. Sometimes it is fused also. If there was a short and the fuse blew you would be without charging, even with a new alternator.

I would also check your grounds and make sure they are clean. There is a separate forum for the TV's, you may also want to ask in there, someone may have some better tips.

06-20-13, 09:22 AM
Which fuse would I need to check? I didn't really lean that way since once the alternator was replaced it had good readings for about 5 mintues before doing the same thing as before.

06-20-13, 11:04 PM
Isn't there a idler pulley? Make sure it's not binding; did you see any power steering warnings on top of all the others. You have changed the belt, right?

06-24-13, 01:26 PM
Ok, so I took the car back to Cadillac on Friday, moral of the story. Don't replace your alternator with a remanufactured one from a parts store, get the GM alternator. I purchased the alternator from Pep Boys and it would give back a reading of 11.4 volts, way too low. Turns out that the alternators need to communicate with the system, and the aftermarket ones just won't cut it.