: Temperature gage



Show24
06-18-13, 07:56 PM
Hey y'all,

I hope al is well with you guys, unfortunately I have a big problem that I can't seem to fix in my own. My temperature gage will not come on, it won't light up nor will it cut on the ac. Could it be a blown fuse or do I need to replace the whole piece or what.

Thanks in advance.

Submariner409
06-18-13, 08:11 PM
The (coolant) temp gauge should have nothing to do with A/C. More info, please ??? 1996 Brougham - Does this car have the bar-type gauge in the panel ??? Any Brougham owners online ???

Show24
06-18-13, 08:20 PM
[ATTACH=CONFIG]117786[/ATTACH

The ac/heat controller. It won't turn on at all

MoistCabbage
06-18-13, 10:45 PM
Wrong Forum, your Fleetwood is RWD.

Is it just the screen that doesn't work, or do the controls do nothing as well.

Ranger
06-18-13, 10:53 PM
:moved:

Show24
06-19-13, 02:24 AM
The controls don't work either. Sorry should I repost this in the other forum?

MoistCabbage
06-19-13, 11:13 AM
It's already been moved for you.

jayoldschool
06-19-13, 11:33 AM
Start by checking all fuses. You don't need to pull them out, just set your meter to beep on continuity, and probe both sides of the fuse. No beep=bad fuse. You can check them all in about two minutes. Check the ones on the door, and the ones under the hood.

Show24
06-19-13, 08:24 PM
Is there a second fuse box somewhere? I checked all the fuses under the hood and everything's good.

jayoldschool
06-19-13, 09:34 PM
Driver's side door jamb, end of the dash.

Show24
06-19-13, 11:27 PM
Got it guys thank you. Fuse was blown, along with a few others. Thanks for the quick help.

jayoldschool
06-20-13, 12:02 AM
Glad to help, and happy it was something simple!