: Service Airbag?



robojesus
06-16-13, 12:23 AM
So I got in my V today to make a trip, and my service airbag light would keep coming on and stopping with bumps and steering... mostly steering. I'm thinking/thought it was my clock spring. I removed the airbag module from the wheel, and checked for loose/broken wires, and found nothing. I put the airbag back together, and alas, the light is on steadily. I'm thinking it saw both airbag sensors were disconnected, so it just threw the code (going to try to clear all codes/dtc's tomorrow morning) and see if it clears up. I also tried mashing the buttons on the wheel when steering, and sometimes they would just not change the option (i.e the tpms/coolant/oil psi/oil temp), and a few other times it just shut off during random tapping. Other times it worked fine as well... mainly when not steering.

What do you guys think? Bad airbag in the wheel? Bad clock spring???

I'm thinking clock spring more than airbag.

Also, where can i get just the clock spring without the harness?

darkman
06-16-13, 09:54 AM
As you probably already know, never work on any part of the air bags system with the battery connected.

The clock spring and harness do not appear to be available seperately.

See attached.

robojesus
06-16-13, 11:54 AM
darkman, would you agree that it's probably the clock spring?

darkman
06-16-13, 12:03 PM
darkman, would you agree that it's probably the clock spring?

I would eliminate the passenger seat sensor as the problem first. As I read the literature, if you get all the codes cleared, you can test the passenger seat with some weight in the seat because if that is the problem you will get a "passenger air bag off" signal before you get a "service air bag" warning.

Also, are there any specific error codes being thrown?

(Frankly, I always have a dealer trouble shoot air bag systems because I don't consider them do-it-yourself territory, but that is just me.)

robojesus
06-16-13, 12:25 PM
Mine is an 04, it doesn't have the sensors in the P/S seat :(

I need to take it to my buddies shop tomorrow and scan it.

robojesus
06-17-13, 10:51 AM
Code is B0022, cleared the codes with my MODIS, and the airbag light is still on.

darkman
06-17-13, 01:10 PM
Code is B0022, cleared the codes with my MODIS, and the airbag light is still on.

See attached.