: 77-79 Delayed windshield wipers

05-30-13, 08:00 PM
My 79 has the delayed wipers and I'm having some issues with them. I thought I posted about this a year or two ago, but I can't find the thread.

I've replaced the dash switch and the front part of the motor that has the washer pump and relays on it, but it didn't help.

The issue is that a lot of times the wipers won't completely turn off, and half the time when they're in delay mode, they don't delay. So, sometimes they work fine, but usually they'll start acting up after a few minutes of use. Like I'll put them in delay mode, and they'll delay for a while, but then they start just going like they're not on delay.

When I try to turn the wipers off, the blades go down, but then keep moving about 4 inches up and down. This usually stops after about 5 minutes, or after I turn the car off and come back to it later.

I have the shop manual I just haven't had time to look through it yet to troubleshoot, and I thought I would see if anyone had any tips.

05-30-13, 11:46 PM
Funny you should mention this as I am having some issues with my '87.

When the wiper switch is moved to the first "click" position (at the very low end of the delay section), they will go in high speed and after about every third swipe, they will park, then go back to high speed again.

When the wiper switch is moved anywhere into the delay section, they work as they should.

When the wiper switch is moved into the "MED" position, they will go at a low speed; will sometimes not work at all or will sometimes go erratically.

When the wiper switch is moved to the "HI" position, they go at a low speed or will go erratically.

Fortunately, most of our rains are anywhere from drizzle to steady rain and can be handled with the delay section...which nearing the top end will create almost a "LOW" speed. If it ever rains very heavily...which happens mostly in spring...I have to play around with the switch near the very lowest setting (nearest the "OFF" position) to get a higher speed.

BTW... I have a FSM for the 1986 model and I'll post what it says about the conditions you mention...I don't know if the systems are similar, but hopefully, this will give you some direction...

Condition: "blades cycle in and out of park position when wiper is shut off":

A: Wiper has both LOW and HIGH speeds - Replace Park Relay

B: Wiper has HIGH speed only - Check for proper terminal contact at wiper motor connector terminal no. 3. If OK, then check "with wiring still connected to wiper motor, connect a jumper wire from no. 3 terminal to ground" If condition still present, remove motor and check for open in shunt field. If wiper has low speed and shuts off OK, then check for open in lead between terminal no. 3 and wiper switch. If ok, check for defective wiper switch.

Condition: "wipers won't shut off - blades operate in normal wipe pattern":

If wipers do not delay between wipes - with wiper switch in OFF position, turn ignition switch OFF, then ON...

A: If wipers do not shut off - check if override switch contacts are opened by projection on rim of ratchet gear. If contacts open, check for grounded blue wiper. If contacts closed, check for loose timing circuit attaching screw. If ok, adjust contacts or replace timing circuit assembly.

B: If wipers shut off, blades park correctly - check holding switch contacts, adjust as required. If ok, replace timing circuit assembly.

There are other tests you can try, but these seemed to be close to what you mention...

Hope this helps.

EDIT: Oops...I just read your last sentence on your post...you have your FSM...oh well...hope this helps anyhow.

05-31-13, 08:23 AM
You need to replace the circuit board that is under the black cover, can't recall name at this time but you can get it at your auto parts store.


Wiper motor pulse board module

06-02-13, 05:45 AM
I'm not sure if that would be the part. I mean, it's not really a circuit board like you would see in a computer. Just a bunch of relays and coils with some mechanical bits and a few wires. Is this the part you're talking about maybe? http://www.rockauto.com/catalog/moreinfo.php?pk=932517&cc=1025491

And I mean, I've tried two different ones now with the exact same result, so I don't know if I'm convinced...

I'm wondering if it might be this guy: http://www.rockauto.com/catalog/moreinfo.php?pk=76034&cc=1025491

Haven't replaced that, and if it's what switches between the modes, it would make sense. I wonder if I can just refurbish it somehow...

06-02-13, 12:18 PM
The part you need if the first link you posted. There may be other items that give you these problems. The delay pump, cam, switch, and circuit is different than the standard wiper. These parts cannot be interchanged. You may be able to go from delay to standard, but not the other way around.

06-02-13, 09:14 PM
Okay, I'll get a new one at some point and try it. I was kind of doubting that was it since I had gotten a different one from pick-n-pull (still from a car with the delayed wipers) and it still did the same thing, but of course it wasn't a new part being from pick-n-pull, and the new one is only $10.

06-02-13, 10:44 PM
Unless its different from my 80 but mine was the wiper motor pulse board module. It did the exact things you mentioned and I tried used wiper switches and nothing. Bought a NOS wiper switch, nothing. Bought new wiper motor and still nothing. Asked a friend who specializes in GM cars,
especially cadillacs and told me to replace the part I mentioned. Bought it new, he put it on for me and wipers now work as they should....

08-04-13, 08:57 PM
Finally ordered the part, but now I'm a little confused. It came with the green pod like they show in the picture, but also an extra circuit board that goes with it. The green pod looks like a direct replacement, but the circuit board, while it looks like I could install it, doesn't have the same connections on it that my unit does.

Here's the extra circuit board:

Here's the green pod:

And here's my wiper motor module with the dust cover removed:

08-05-13, 04:10 AM
i've got the same problem on my 89 Brougham, here's my thread about it. There's some really good advices in there. But it's probably cracked soldering joints in the circutboard that's your problem. Have it checked, and if it is, you can fix it in under 2minutes with some a new soldering. http://www.cadillacforums.com/forums/rwd-19xx-1984-deville-fleetwood-1985/338250-wiper-time-delay-not-working-properly.html

08-11-13, 08:16 PM
I'm not so sure it's cracked solder. I can't see any cracks. After thinking about it more, it seems like a relay sticking on. When it first starting happening, I would turn the wipers off and then they would do that thing for about 5 minutes and then finally stop. Like maybe something was hot and finally cooled off or something. Now of course it's worse and I never know when they're going to stop, but usually they finally do after the car has been off for a while.

08-12-13, 09:59 AM
All your delay is the reaction the "green pod" controlled by the position of the switch.

08-12-13, 10:14 AM
I just finished fixing mine on my 78 fleetwood. The contacts may look ok where the wires plug in but they oxidize bad. What I did was took everything apart, cleaned all of the contacts with brasso, and re-assemebled everything. One thing I have noticed is there are no correct replacement controllers for the 77-79 systems. If you purchase an aftermarket replacement unfortunately you will loose the delay. The piston on my pump was also shot. I purchased an after market unit took the pump from it and transfered it to mine. Then I cleaned all of the contacts for the wiring and also the contact that runs off of the cam for the wiper delay. This may be there problem on yours. Clean the cam contact off with some brasso and make sure it is not bent. Put everything back together and you should be good to go. I see there are 2 resisters wired in on these units also. Make sure they are not broken and check the resistance with a meter. If they don't check out you could probably replace them with resisters picked up at a local electronics shop. Since you have the relay I would also transfer over the new green relay.

08-25-13, 04:16 PM
I played around with mine some more today. Cleaned the contacts and all and put the new relay in. Without the engine on, everything works as expected except for the washers. It won't spray with the engine off, but, the wipers turn off just fine when the engine isn't running.

If I turn the engine on, then the washers spray, but the wipers will not turn off properly; they just stay on but only move about 8 inches as I've described before.

So then, with the wiper switch set to off, I turned off the engine, turned the key back to accessories, and the wipers moved all the way down and turned off just fine.

Guess I'll study the diagram in the FSM some more to see why that might be.

09-02-13, 04:56 PM
Blarg! I called a mechanic and he suggested replacing the motor. Did that and things seemed good at first. It rained today so it was perfect timing for a test. So with the new motor, but the washer pump/relay/circuit I was using before, it seemed like it was turning off just fine. But then after running it for about an hour, it started doing "it" again!

I think my next plan will be to take the circuit board and replace every component on it with brand new ones and solder it up.

EDIT: Okay never mind scratch that. I went and tried messing with it again and I couldn't get it to do the thing, but then I noticed the washer pump wasn't going either. I had the cover off, so I took a pair of pliers and moved the little black notched thing in the middle, and then the washer pump started going, but it kept going in every mode. Then I moved the metal arm with the pliers and the black notched thing rotated and the washers stopped. Next I flipped through the modes with the dash switch, and everything seemed to be working, it turned off fine, but when I went to mist mode, it did the thing it had been doing in off mode! I fiddling with the black notched thing again and then everything went back to normal. So it seems like maybe something mechanical is just getting stuck sometimes?! So annoying. Maybe I just need to replace the whole washer pump.