: 2008 SRX starting problem ONLY after getting fuel



winddyy
05-28-13, 05:34 PM
The problem started about 1 month ago: the engine acted like it was flooded; i had to start the car 4-5 times before it will start up. After that, the car starts normally and runs great until the next fuel fill-up. I have tried different gas companied and also used fuel treatment but no luck fixing it.

Does anyone else have this problem? Any suggestions?

Thanks in advance for any help.

1BadCadSTS
05-28-13, 06:14 PM
Sounds like fuel pressure regulator. Pull the vac line off turn key on and see if fuel drips from it.

glake89
05-28-13, 06:15 PM
Check for DTCs even though the MIL light isn't on. Maybe a new gas cap? Check all engine grounds you can find incl. battery neg. cable.

conedoctor
05-28-13, 06:22 PM
I vote for gas cap.

drod777
05-28-13, 08:58 PM
Have had the same problem and now having to replace the solenoids. replaced the gas cap and that did not help had #P0446 DTC

08SRX
05-29-13, 12:42 PM
Another area could be a clogged fuel filter, especially if the problem gets worse over time and you start getting hesitation on acceleration as well.

Sackett
05-31-13, 07:57 AM
Had a similar issue last year on our '08 but it wasn't after fill up. It had been sitting for a bit and went to start it. Wouldn't start and had bad fuel smell. Finally got it started, and it ran rough for a minute until it cleared up. I guessed some kind of weird vapor lock issue, hasn't happened since.

Cadillac Cust Svc
05-31-13, 12:00 PM
Had a similar issue last year on our '08 but it wasn't after fill up. It had been sitting for a bit and went to start it. Wouldn't start and had bad fuel smell. Finally got it started, and it ran rough for a minute until it cleared up. I guessed some kind of weird vapor lock issue, hasn't happened since.

Hello Sackett,

I am happy to hear your vehicle hasn't had the start up issue recently. I hope you are enjoying driving your SRX around!

Regards,

Laura M.
Cadillac Customer Service

----------


The problem started about 1 month ago: the engine acted like it was flooded; i had to start the car 4-5 times before it will start up. After that, the car starts normally and runs great until the next fuel fill-up. I have tried different gas companied and also used fuel treatment but no luck fixing it.

Does anyone else have this problem? Any suggestions?

Thanks in advance for any help.

Hello winddyy,

I am sorry your vehicle is having start up issues. I see other members on this forum have given good insight on the situation and possible solutions to it. If you want to discuss your concerns or issues further, please reach out to us via private message.

Sincerely,

Laura M.
Cadillac Customer Service

winddyy
06-24-13, 04:10 PM
It was the Evap Solenoids; replaced it and no problem since. Thanks for all the inputs/advices. This forum rocks.