: Stability System Activated?



titustogi
05-22-13, 07:02 PM
Hey guys,
I have a question about 2002 cadillac escalade. My stability system would activate when turning so i changed my wheel sensor and it stopped for 2 weeks. It started again and my mechanic told me the tires were giving off different readings because two tires were bald. So I just replaced all 4 tires and the stability system is still activating when turning on dry pavement. Any suggestions on why this is happening?

Tdub80
05-22-13, 08:23 PM
I have the same issue on my '04. Changed wheel hub etc and still doing it. Might be the wire that goes from ABS to firewall. Working on the solution..

the cadillac man
05-22-13, 10:49 PM
Hey guys,
I have a question about 2002 cadillac escalade. My stability system would activate when turning so i changed my wheel sensor and it stopped for 2 weeks. It started again and my mechanic told me the tires were giving off different readings because two tires were bald. So I just replaced all 4 tires and the stability system is still activating when turning on dry pavement. Any suggestions on why this is happening?

Could be a bad sensor

titustogi
06-28-13, 06:22 PM
I have replaced the yaw sensor yet it still does it

the cadillac man
06-29-13, 12:19 AM
I have replaced the yaw sensor yet it still does it

I meant a wheel speed sensor

reddzspace22
06-29-13, 12:33 AM
Ebcm could be starting to go bad. Did your mechanic check for any dtc's in module??

titustogi
06-29-13, 12:35 PM
I took it to the dealer they changed one of the wheel position sensor and the yaw rate sensor. I dnt know if they calibrated the ebcm after replacing the yaw rate sensor