: Central door lock problems?



jetson22
05-22-13, 11:03 AM
I have a 02 Denali. Last night going down the road the electronic central locking system just started to activate off and on until finally it quit and now does not work at all. Using the remote it will still kick on the lights but nothing from the locks. Any help appreciated. Thanks

----------

I just checked the appropriate fuses in side panel. All seem ok, however when I place each fuse back in I can hear the click but the central lock doe not engage. I did not check the two big black lock & unlock relays (7866). Do they just pull out and how do you tell if they are bad? Thanks.

the cadillac man
05-22-13, 11:51 AM
I have a 02 Denali. Last night going down the road the electronic central locking system just started to activate off and on until finally it quit and now does not work at all. Using the remote it will still kick on the lights but nothing from the locks. Any help appreciated. Thanks

----------

I just checked the appropriate fuses in side panel. All seem ok, however when I place each fuse back in I can hear the click but the central lock doe not engage. I did not check the two big black lock & unlock relays (7866). Do they just pull out and how do you tell if they are bad? Thanks.

If the relays makes a weak click then they need replacing
But the sudden locking and unlocking sounds like a door module

jetson22
05-22-13, 01:53 PM
Do you just pull out the relays from the fuse box? How can you tell if they are bad?

the cadillac man
05-22-13, 01:58 PM
Do you just pull out the relays from the fuse box? How can you tell if they are bad?

Yep they just pull out both are the same I would replace them to see if the locks work or not

jetson22
05-22-13, 02:04 PM
Thanks, I will give it a try!