: intermitent hesitation on aceleration



ross_g
05-17-13, 09:54 AM
I have a 2006 escalade ext that has developed an interesting problem. sometimes from a stop if you give it gas it starts to accelrate than falls on its face. let off the gas and press the pedal again the same thing will happen. then it will finally go down the street and act as if nothing has happened. no codes except for a wheel speed sensor code c0035 and a steering code c0455.
Also sometimes when driving down the road at 25-35mph the truck will drop power then come back to full power this will happen several times then go away. it will also idle high aprox1000 rpm when coming to a stop but will accelerate normaly.

recent service work truck gave a misfire code on cyl 5 at that time replaced spark plugs with factory plugs new wires intake manifold gasket new air filter and cleaned throttle body. I have driven close to 3000 miles since that was all done before this issue started.

If anybody has had a similar problem please let me know what resolved your issue I don't know where to start at this point. the problem is so intermitent and without a code I am a little lost :ill:

grayparatrooper
05-17-13, 03:21 PM
i had similar probs in my lexus and the fuel pump was on its way out.

the cadillac man
05-17-13, 07:41 PM
I have a 2006 escalade ext that has developed an interesting problem. sometimes from a stop if you give it gas it starts to accelrate than falls on its face. let off the gas and press the pedal again the same thing will happen. then it will finally go down the street and act as if nothing has happened. no codes except for a wheel speed sensor code c0035 and a steering code c0455.
Also sometimes when driving down the road at 25-35mph the truck will drop power then come back to full power this will happen several times then go away. it will also idle high aprox1000 rpm when coming to a stop but will accelerate normaly.

recent service work truck gave a misfire code on cyl 5 at that time replaced spark plugs with factory plugs new wires intake manifold gasket new air filter and cleaned throttle body. I have driven close to 3000 miles since that was all done before this issue started.

If anybody has had a similar problem please let me know what resolved your issue I don't know where to start at this point. the problem is so intermitent and without a code I am a little lost :ill:

Sounds like the fuel pump is taking a crap on you

Cadillac Cust Svc
05-17-13, 11:36 PM
I have a 2006 escalade ext that has developed an interesting problem. sometimes from a stop if you give it gas it starts to accelrate than falls on its face. let off the gas and press the pedal again the same thing will happen. then it will finally go down the street and act as if nothing has happened. no codes except for a wheel speed sensor code c0035 and a steering code c0455.
Also sometimes when driving down the road at 25-35mph the truck will drop power then come back to full power this will happen several times then go away. it will also idle high aprox1000 rpm when coming to a stop but will accelerate normaly.

recent service work truck gave a misfire code on cyl 5 at that time replaced spark plugs with factory plugs new wires intake manifold gasket new air filter and cleaned throttle body. I have driven close to 3000 miles since that was all done before this issue started.

If anybody has had a similar problem please let me know what resolved your issue I don't know where to start at this point. the problem is so intermitent and without a code I am a little lost :ill:

Hello ross_g,

Was the recent service you had done on your Escalade done at a GM certified dealership? I apologize for these concerns you are having with your vehicle.

Sincerely,

Laura M.
Cadillac Customer Service

ross_g
05-29-13, 09:35 AM
Hello ross_g,

Was the recent service you had done on your Escalade done at a GM certified dealership? I apologize for these concerns you are having with your vehicle.

Sincerely,

Laura M.
Cadillac Customer Service

Hi Laura
I did the repairs myself I am a ase certified tech I however no longer have acces to a tech 2 machine. I have verified my repairs no leaks proper torque sequence performed etc. There is no skip in the motor at all. I had a similar problem with an 02 avalanche I owned however that vehicle would set a throttle code and go into limp home mode. It acts like the throttle is not communicating with the throttle plate. Unfortunatly since they closed the local cadillac dealership I have no techs to talk to about this problem so now I have to rely on the internet and motoralldata for the information I need.

The high idle situation acted up on me again this past week while on a 300 mile round trip to vermont. while towing my car trailer became kind of interesting when trying to stop at a rest stop. was traveling at 70 mph with the cruise control on in tow mode trailer empty. noticed the truck slightly doing the accelarator clunk issue. I pulled over at a rest stop Idle was around 1200 rpm in nuetral then came down to 900 rpm after stopping. shut truck off for a few minutes came back to truck started it ran fine for the rest of my journey and has been fine since.

Cadillac Cust Svc
05-29-13, 11:48 AM
Hi Laura
I did the repairs myself I am a ase certified tech I however no longer have acces to a tech 2 machine. I have verified my repairs no leaks proper torque sequence performed etc. There is no skip in the motor at all. I had a similar problem with an 02 avalanche I owned however that vehicle would set a throttle code and go into limp home mode. It acts like the throttle is not communicating with the throttle plate. Unfortunatly since they closed the local cadillac dealership I have no techs to talk to about this problem so now I have to rely on the internet and motoralldata for the information I need.

The high idle situation acted up on me again this past week while on a 300 mile round trip to vermont. while towing my car trailer became kind of interesting when trying to stop at a rest stop. was traveling at 70 mph with the cruise control on in tow mode trailer empty. noticed the truck slightly doing the accelarator clunk issue. I pulled over at a rest stop Idle was around 1200 rpm in nuetral then came down to 900 rpm after stopping. shut truck off for a few minutes came back to truck started it ran fine for the rest of my journey and has been fine since.

I am glad you were able to repair your vehicle ross_g. I understand how you rely on the Internet for technical advice, seeing how you are not close to a dealership anymore. These forums are awesome and a great way to help each other out; a lot of people are very knowledgeable on their vehicles and how they operate. I am happy everything worked out after shutting your truck off for a few minutes while on your road trip. It can be frustrating having your vehicle not function correct while traveling. Glad to know your vehicle has ran fine ever since!

Sincerely,

Laura M.
Cadillac Customer Service