: Strange issue with factory MP3 player (2013 CTS Coupe)



gggoodgggirl
05-17-13, 07:00 AM
I am experiencing something very odd with the MP3 player in my new CTS Coupe. When I am playing a home-made MP3 in shuffle mode, the player seems to pick one song and repeat it every other song. Sometimes it plays that same song continuously, but usually its every 2nd song. And its always the same song... I am not sure if its relevant, but the file name of this song on the disc starts with a number, rather than a letter.

Its not the disc... the disc works perfectly in other players. Has anyone else experienced this?

I realize this seems relatively minor, of all the things that could go possibly wrong, but its actually quite annoying.

Thanks in advance for any insights,
Jill :)

ajazolino
05-17-13, 09:17 AM
You should probably just get an iPod. And do away with mp3 discs. Too much of a hassle.

is250sp
05-17-13, 09:52 AM
Forget iPod, use the internal hard drive. All you need is to get a cheap flash drive, load your mp3's onto them, connect to your car, and then press Record.

rchern
05-17-13, 10:27 AM
When I'm in bed a little kid appears and says "redrum".

hauler
05-18-13, 04:19 PM
Its not the disc... the disc works perfectly in other players. Has anyone else experienced this?

Thanks in advance for any insights,
Jill :)
Do the other players shuffle the songs and not have a problem? Does the car player play the sequence correctly when shuffle is not invoked? If yes to both, it sound like the shuffle algorithm software has an error.

CTSCHICK
05-18-13, 04:32 PM
I use a 16 GB usb flash drive for my music in my center console with the stereo permanently set for shuffle no problems with the shuffle function.

But I did notice occasionally the stereo will skip to the next song while another song is already playing and before it is finished.

A lot better than repeating a song that would drive me nuts to. lol

gggoodgggirl
05-20-13, 07:26 AM
Forget iPod, use the internal hard drive. All you need is to get a cheap flash drive, load your mp3's onto them, connect to your car, and then press Record. My CTS does not have an internal hard drive.


Do the other players shuffle the songs and not have a problem? Does the car player play the sequence correctly when shuffle is not invoked? If yes to both, it sound like the shuffle algorithm software has an error. Interesting question - I played with it a bit yesterday and experienced something interesting. When I turned shuffle off, it correctly played the songs in the order they are on the disc, but the player still displayed the word "shuffle" on the display. Then I turned shuffle back on and it randomized correctly, but that one song still played every other song. Then, using the menu controls I selected an ""Artist" category and it correctly shuffled just the songs from that selected artist.

So now I am thinking there are 2 things wrong...
1) when shuffle mode is "on" at the parent level of the disc, it is confused by that song (for some unknown reason)
2) when shuffle mode is "off", it displays "shuffle" on the display (the reason I know it is "off" is that the songs play in the order they were recorded onto the disc.)

Another note that may offer some explanation - this songs on this disc are in alphabetical order by file name... so the song which starts with a number is the first song on the disc... so the issue could be that the file name starts with a number OR the issue could be that it keeps returning to the first item on the disc.

If it is a software algorithm issue, is this something Cadillac should fix under warranty?

Citabria
05-21-13, 12:20 AM
I believe shuffle will always display. When the background is hi lighted in the shuffle tab it is on an when not it is off.

is250sp
05-21-13, 02:39 PM
I use a 16 GB usb flash drive for my music in my center console with the stereo permanently set for shuffle no problems with the shuffle function.

But I did notice occasionally the stereo will skip to the next song while another song is already playing and before it is finished.

A lot better than repeating a song that would drive me nuts to. lol

I believe this is a bug as I experience the same with some of my songs copied from USB to hdd. It's as if only a portion of the song was able to be read. The fix for me was to get another copy of the song and re-upload.