: 70 DeVille Blower blows on low only



Jeff R
05-15-13, 10:00 PM
Hello,
I am new to the forum--- Just bought a 70 Coupe DeVille today.

I am sure I will have several questions to post here but my first question is about the a/c blower.
It has the auto climate control. The a/c compresser kicks on and I get somewhat cold air. However the blower blows only on low.
How do I check this to see where the problem is--- or for simplicity, can I just hot wire the blower on High for now? The windows don't work so I really need the a/c.
Thanks to all.

Jeff

smelvis
05-16-13, 10:23 PM
Hi Jeff,


I have a 70 dv and she sat for a while. Had the same problem. The blower is always on low even if the system is off. The air system is purged and vented into the engine compartment. I couldn't get mine to blow hard and after checking the elec connections a buddy told me to slide the switch back and forth a thousand times and even had me spray WD 40 in there. He suggested that because over time the contacts corrode. It worked for me. Might be worth trying.

Jeff R
05-23-13, 09:03 PM
I'll try it, thanks

klinebau
05-28-13, 12:13 PM
You should get a copy of the factory service manual (electronic copies can be found online for reasonable prices). There are few items that are needed in order for the blower to kick into high speed. There is a relay for the blower in the engine compartment on the firewall. Also, the power servo needs to receive the correct signal(s) from the switch in the dash panel. The resistors for the blower are in the power servo.