: steering misalignment



lokoh
05-12-13, 07:40 PM
So I was backing out of the driveway today and felt a little slip in the steering. Heard a little grunt from the front end and when I started moving forward, I noticed that my steering wheel was pointed about 30 degrees to the left when driving straight. Shortly afterward ,the service stabilitrac light came on and stayed on. So now, when driving in a straight line, my steering wheel is about 30 degrees off center. WTF is wrong here? My mods are eibach coils, intake and exhaust. That's it! Anyone else have this problem. Know what went wrong. 2012 M6 wagon with less than 2000 miles.
Thanks

V-swagon
05-12-13, 07:46 PM
Was everything torqued after the Eibachs were installed?

lokoh
05-12-13, 07:53 PM
Was everything torqued after the Eibachs were installed?

I didn't install the coils myself, but the shop I use is pretty top notch. They do a lot of the Overhaulin cars here in Huntington Beach. I've been using them for years, without problems. Don't see how installing coils would affect the steering.

V-swagon
05-12-13, 11:19 PM
The only reason why I asked is I just installed Eibachs on my V wagon. The front upper control arm has to come out along with the spring/strut.

Mr.electric
05-12-13, 11:39 PM
I would get it checked ASAP. I might even tow it into the shop. Something is loose and if it lets go while you are on the freeway it won't be pretty. Since the car still drives in a straight line it is probably something that effects left and right. The clamps and rubber bushings that hold the rack down could be loose. Anyways it does not sound safe to drive in my opinion.

ctsvracingalan
05-13-13, 03:31 PM
When you lowered your car they may have forgot to adjust you steering shaft it needed to be adjusted and the steering knuckle may be hitting itself when you turn wheel

lokoh
05-13-13, 10:03 PM
Problem was a loose bolt for the lower control arm adjustment slot. Shop realigned it and its all good now. Thanks for the help everyone

ENVIOUS V
05-14-13, 12:10 AM
Hey at least you took care of it and the bolt didn't fall out.

V-swagon
05-14-13, 11:20 PM
Problem was a loose bolt for the lower control arm adjustment slot. Shop realigned it and its all good now. Thanks for the help everyone

Good to hear that it's fixed.