: Purchased a new truck and have a few questions/issues



Stresst
05-12-13, 12:38 AM
I just picked up a 2010 Platinum and the DVD/TV in the passenger side headrest doesnt work. It power up I see the blue lights illuminate but nothing on the screen. Any suggestions?

There is play in the hood, when I drive on the highway you see it flapping. I tried opening and slamming it tight but there is play......What needs adjusting? I tried turning the rubber stops but couldnt break them loose.

Any help would greatly be appreciated!

chakde
05-12-13, 01:52 AM
Did you try changing the input on the headrest that shows blank. Also try on load a dvd to that headrest directly to see if that works.

For the hood see if spraying some wd40 on the stoppers help turning them

shore
05-12-13, 08:42 AM
The rubber stoppers are just that, stoppers. They screw in and out. You might also try moving the latch downward to apply more tension.

Rolex
05-12-13, 10:08 AM
Spray some WD 40 on the threads of the rubber stoppers and let it soak. You'll have to adjust them up some to make them rest against the hood to hold it steady. Don't adjust them up so much that you can't shut the hood without forcing it down.

Stresst
05-12-13, 10:20 PM
Did you try changing the input on the headrest that shows blank. Also try on load a dvd to that headrest directly to see if that works.

For the hood see if spraying some wd40 on the stoppers help turning them

I will spray them up tomorrow, hopefully that works.

As far as the headrest I put a DVD directly into the headrest but NG......