: This is driving me insane enough to actually come back here and post...



Playdrv4me
05-10-13, 06:20 AM
Does anyone know how the 2008 Escalade supernav decides what the heck to use as the startup channel on the radio? It seems like ever since the battery died once (and it may have been happening even before then, I just can't remember), the radio just arbitrarily sets the startup station, usually from one of the presets. Currently I listen to a lot of SXM Public Radio, Road Dog Trucking and a few others. Right now, even if I shut it off on AM/FM radio or Road Dog or one of my other presets, it has decided that it wants to go BACK to SXM Public radio every single time you start it. Then arbitrarily three weeks from now it might start using RoadDog again or one of the other channels if I listen to one of those. Then every single time for WEEKS it will start up with that station. It always starts with a selected station, then it runs with that station for weeks at a time until it "catches" on another station listened to and starts using that one. It's as if whatever the mechanism is that tells it what station you shut it off at is simply being ignored.

This has gone from a minor annoyance to a full blown war as I figure out why it's doing this. Any ideas before I pull the negative battery cable and attempt a hard reset? Surely this isn't a "feature".

The only external mitigating factor is that I have an iPod connection kit that passes through the XM input. It's been so long since I put it in I don't even remember which brand it is... PA something GM probably. But this didn't happen on the '07 I had a similar unit in. Also, it can just as easily decide it wants to make a startup station out of the regular radio as well.

48Dodge
05-10-13, 02:23 PM
Occasionally I'll be listening to XM, take or make a phone call and when I end the call it will go back to whatever station I was listening to on FM. Doesn't happen every single time, but enough to notice that it's definitely a glitch.

CadX6
05-10-13, 02:58 PM
Do you have an iPod adapter that plugs into your XM receiver installed? I had a PA20-GM in my 09 & every time my son borrowed the car & changed the channel, after I got it back it would revert to what he had it on every time I started the car, even though I had changed it back to my channel before I shut it off. Removing the PA20-GM solved the problem.

Playdrv4me
05-10-13, 05:45 PM
Do you have an iPod adapter that plugs into your XM receiver installed? I had a PA20-GM in my 09 & every time my son borrowed the car & changed the channel, after I got it back it would revert to what he had it on every time I started the car, even though I had changed it back to my channel before I shut it off. Removing the PA20-GM solved the problem.

Yeah I either have that one or whatever the other brand is, but I brought that over from my '07 Lade and I don't remember it doing that. That has to be it then. I don't want to take that out so I guess I'll just live with it.

CadX6
05-11-13, 02:08 PM
If you have the one that plugs into your XM receiver behind the glove box, it would be real simple to just unplug it, plug the cable from the head unit back into the XM & see if that fixes the problem - no tools required - don't even have to remove the iPod adapter.
Now, if you have the one that mounts behind the head unit - that's another story........