: WTH... I just installed a new O2 sensor to fix P0054, cleared, now P0141 is the same?



Sentinelist
05-05-13, 01:11 PM
After hammering the throttle across the Florida panhandle on a recent trip, I burned up one of my O2 sensors. P0054 was the code that resulted. After finding out that was Bank 1 Sensor 2, I ordered a new Denso unit, installed it, and went to have the code cleared, only to have it come right back. OK, maybe some of the image searches online had this backwards. I swapped the new O2 to the other (passenger) side. I should note I accidentally dropped the original O2 sensor I was replacing from about 2'. Put it back on the driver's side. Code cleared, now coming back as P0141! But still Bank 1 Sensor 2?? Or did I miss something?

I'm highly confused. And annoyed. Since the ESV is now late for its state inspection. Any advice?

TLMC
05-05-13, 04:32 PM
Check the cat itself. Both of mine went out at about the same mileage you have.

the cadillac man
05-05-13, 05:34 PM
Check the cat itself. Both of mine went out at about the same mileage you have.

That is possible and it can effect the 02 sensors and foil up your plugs in the process

wesyder
05-05-13, 06:03 PM
After hammering the throttle across the Florida panhandle on a recent trip, I burned up one of my O2 sensors. P0054 was the code that resulted. After finding out that was Bank 1 Sensor 2, I ordered a new Denso unit, installed it, and went to have the code cleared, only to have it come right back. OK, maybe some of the image searches online had this backwards. I swapped the new O2 to the other (passenger) side. I should note I accidentally dropped the original O2 sensor I was replacing from about 2'. Put it back on the driver's side. Code cleared, now coming back as P0141! But still Bank 1 Sensor 2?? Or did I miss something?

I'm highly confused. And annoyed. Since the ESV is now late for its state inspection. Any advice?

P0141 shows heater circuit, that should not be related to the condition of the catalytic, check continuity on the heater side of the sensor if it checks out then start the diag on the vehicle side

Sentinelist
05-05-13, 11:26 PM
First thing's first... if you're standing in front of the truck... is bank 1 the left (passenger) side?

I was hoping it wasn't the cats... I also had to replace both of them on an 04 Grand Cherokee Ltd. last year (right before I sold it, the ESV replaced it) at a similar mileage. Actually got decent units off Amazon...

the cadillac man
05-06-13, 02:16 AM
First thing's first... if you're standing in front of the truck... is bank 1 the left (passenger) side?

I was hoping it wasn't the cats... I also had to replace both of them on an 04 Grand Cherokee Ltd. last year (right before I sold it, the ESV replaced it) at a similar mileage. Actually got decent units off Amazon...

Bank 1 is the drivers side bank 2 is the passenger side

Sentinelist
05-06-13, 11:02 PM
Thanks. I swapped the new sensor back to bank 1, had it reset, and it's come back again... does not show for both sides, just Bank 1 Sensor 2 still (both codes, redundantly).

Is it the cat in that case? It seems like it, but I'd like some competent confirmation from someone who knows for sure. And if so, Magnaflow or Walker? Or recommendations? I would go ahead and do both if I must...

the cadillac man
05-06-13, 11:31 PM
Thanks. I swapped the new sensor back to bank 1, had it reset, and it's come back again... does not show for both sides, just Bank 1 Sensor 2 still (both codes, redundantly).

Is it the cat in that case? It seems like it, but I'd like some competent confirmation from someone who knows for sure. And if so, Magnaflow or Walker? Or recommendations? I would go ahead and do both if I must...

I would check the wiring for possible damage before replacing stuff like this

Sentinelist
05-07-13, 01:00 AM
I would check the wiring for possible damage before replacing stuff like this

Which part of what wiring specifically?

the cadillac man
05-07-13, 01:13 AM
Which part of what wiring specifically?

The wiring for the 02 sensors as it sounds like a wiring issue since you tried the sensor in a different position and the issue didn't move with the sensor
They go to the PCM if you want a wiring diagram to check continuity I can email you one
If the wiring checks out then it may be the PCM going flaky(it is possible)

Sentinelist
05-07-13, 12:44 PM
Ok, I don't have a great way to do this beyond looking at the wires at the harness and making sure they're still snuggly in place. Maybe I need to visit a muffler shop like Midas to diagnose/check continuity? Or is there an easy DIY way to do so? You can E-mail me what you have at forums at synthesistechnologies dot com. Thanks.

the cadillac man
05-07-13, 03:53 PM
Ok, I don't have a great way to do this beyond looking at the wires at the harness and making sure they're still snuggly in place. Maybe I need to visit a muffler shop like Midas to diagnose/check continuity? Or is there an easy DIY way to do so? You can E-mail me what you have at forums at synthesistechnologies dot com. Thanks.

If you don't feel confident at doing it then I would suggest going to the muffler shop(just let them know what you have done so far)

Sentinelist
05-08-13, 10:36 PM
Ha, plenty confident, just don't know what to check (nor do I have a good tool to do it). Taking this to Midas in the next few days. Will post back.

the cadillac man
05-09-13, 01:13 AM
Ha, plenty confident, just don't know what to check (nor do I have a good tool to do it). Taking this to Midas in the next few days. Will post back.

Ok I would go to a muffler shop if you ain't got the tools to do it
I wasn't questioning your confidence one bit

Sentinelist
05-28-13, 11:57 AM
It was indeed a wiring issue! According to my shop, the driveshaft somehow tore up the wiring harness- explains why replacing the sensor did nothing. They repaired the harness for 2 hours of labor and the CEL went away, and so far is staying away. I'll probably run it up to the OK border and back tonight to make sure so I can get it inspected ASAP now- am a month late. Very happy with this result. Tempted to put the original O2 back in but won't tempt fate... will at least have a working spare I can use in a pinch now. But FYI for anyone else who runs into this, odd resolution for sure.