: engine over heating..



sannerj
05-04-13, 12:40 PM
hi guys".. 2002 deville dts.. 4.6 northstar, 172xxx mi. I have an overheating issue, I've replaced a cracked radiator, thermostat, used prestone 50/50 all makes/models antifreeze, purge line is working awesome, did the combustion gas test (stayed blue), fresh oil change, with Castrol gtx 5w30.. still over heats, but I get no heat in the cab. just blows cold. both engine fans work as they should.. could it be the water pump ? I drove it 8 miles, after checking everything as stated above.. she almost red lines, had the temp light come on, heard a ding. so I pulled over and let it cool down.

CadillacLuke24
05-04-13, 03:53 PM
When did you do the block test? It should be done right after an overheating episode.

I hate to say it, but it does NOT sound good. If the purge line works, antifreeze is full to the cold mark, the fans are on like they should be, and you get NO HEAT in the cab, well, that strongly suggests HGs. :(

sannerj
05-04-13, 05:11 PM
hmmm.. I did the combustion gas test. at operating temp. gauge stayed at 12:00- the blue liquid stayed blue. I ran it in the driveway for 30 min. rev. from 600 to 2g's. back n forth slowly. gauge never moved. only seems to do it while actually driving the car. I do have heat in the cab now, works awesome.. but I drive 1 mile, the temp gauge starts to climb.. puzzled = me

JoeTahoe
05-04-13, 06:12 PM
If the purge line is flowing than your water pump is working, sounds like headgaset :(

maeng9981
05-04-13, 07:02 PM
I believe the heater core is a full flow unit and it will only be airbound when there's air present in the system. If your purge line is not clogged and it still gets airbound, then something somewhere is injecting air into cooling system - most cases, a failed HG.

The stubborn ones that idle all day long give up when you brake torque it (brake pushed hard and revving in D to 2000 rpm or so). Normal car will be fine while brake torquing. The one with HG will straight out overheat.

Perform the block test after an overheat episode.

sannerj
05-04-13, 07:24 PM
OMG... I found the culprit.. would you believe..? a faulty cap on the reservoir tank.. I never thought about a closer look at it, ( cause it appeared new ) then when I did.... shebang, there it was. seals were all cracked and brittle. thanks for all the help guys, now to put the plugs in. still thinking of a new water pump though. its the only "old" thing left to the cooling system. I tell ya guys, it really had me stumped. got the car a week ago today, 3400.00 cash, "as-is" ofcourse. I knew from the slight miss it would need sparkplugs though. the over heating problems started on day 2. when I discovered the cracked radiator. I hope what I've found, and with your input,, someone else gets help from this..:thumbsup:

Submariner409
05-04-13, 07:48 PM
Water pump - and drive belt system. Several threads in Discussions, Cadillac Tech Tips. Special socket, special procedures, install the new design water pump housing cover and seal ("gasket")

Pictures, diagrams in my albums - The Community tab, Albums, the two of the red Seville - 2 albums, 118 pictures, circuits, diagrams.

To find stuff in here quickly, Google "cadillac forums northstar water pump replacement" or something close. For other searches, always precede the system or part with "cadillac forums .............."