: Front A/C fan not blowing



sprink60
05-03-13, 12:45 AM
It operates while underway but when I stop it slows way down...what gizmo is acting up to cause this to happen?

wesyder
05-03-13, 01:02 AM
It operates while underway but when I stop it slows way down...what gizmo is acting up to cause this to happen?

If its the blower motor acting up, possibly the blower motor resistor

the cadillac man
05-03-13, 01:24 AM
It operates while underway but when I stop it slows way down...what gizmo is acting up to cause this to happen?

Either the blower motor or blower motor control module

sprink60
05-04-13, 12:58 AM
Thanks guys...seems like this afternoon it started working as it should...but I can't explain why. FYI...some times while sitting at a stop I hear a strange tapping from behind the dash on the passenger side...any thoughts on this one?

the cadillac man
05-04-13, 03:08 AM
Thanks guys...seems like this afternoon it started working as it should...but I can't explain why. FYI...some times while sitting at a stop I hear a strange tapping from behind the dash on the passenger side...any thoughts on this one?

The tapping is the actitutior traveling(or dithering) but if the blower motor isn't working it can only one of two things bad blower or bad blower control module(both are easy to replace)

To rid the traveling pull the hvac fuse in the under hood box for a couple mins then put it back in turn the key to run for a couple mins then back off and start the truck the hvac system should do a relearn process(mine did this and that is how I fixed it)

sprink60
05-04-13, 02:36 PM
I will try this. Mine is also doing the "fan/blower running after shut down" dealeo. Have you replaced your blower resistor/module? Is this a common part?

the cadillac man
05-04-13, 02:50 PM
I will try this. Mine is also doing the "fan/blower running after shut down" dealeo. Have you replaced your blower resistor/module? Is this a common part?

If you blower is running with the key off then its the blower control module

sprink60
05-04-13, 03:04 PM
Is it this part?

https://acdelcooutlet.com/index.php/15-80567.html

the cadillac man
05-04-13, 04:32 PM
Is it this part?

https://acdelcooutlet.com/index.php/15-80567.html

It looks like its the right part

sprink60
05-11-13, 09:50 AM
OK..it was the resistor. GM has a kit that upgrades the resistor to a new style and it comes complete with a retro-fit pigtail and instructions....$60 out the the door at http://stores.ebay.com/Number-1-Gm-Parts. They are local for me so I just walked in a picked it up.

wesyder
05-11-13, 03:13 PM
OK..it was the resistor. GM has a kit that upgrades the resistor to a new style and it comes complete with a retro-fit pigtail and instructions....$60 out the the door at http://stores.ebay.com/Number-1-Gm-Parts. They are local for me so I just walked in a picked it up.

Sweet