: Do I need a new battery



dnett
04-30-13, 05:16 PM
Last week I was waiting to pick up my son from school. With the engine off, I sat for about 15-20 minutes with the radio running, but not jamming. My other son adjusted the seat a little and I opened the sunroof and maybe raised and lowered a window.

When I tried to start back up - just clicking. I had to get it jumped.

If I have the battery display on when starting the car, it starts at about 13.0 and rises to around 14.3 or 14.4. I don't have anything to test it before starting. I took the car to a car parts place and had them check the battery and was told that its got about 430+ cranking amps and that it is OK.

It's a 2006 Northstar 1SF. I bought it 4 months ago. I believe this is the original battery.

So, do I need a new battery? I know all the electronics is hard on the battery, but 20 minutes seems awful short to need to get jumped.

Thanks for any help.

curtc
04-30-13, 05:25 PM
430CCA (cold cranking amps) seems very low to me...most batteries should range from 600-800CCA's as far as I know.

The STS is VERY hard on batteries and pretty much eats them for breakfast from what I've read, lots of modules and sensors to power.

Is this the original ACDelco battery from the factory?

dnett
04-30-13, 06:04 PM
Yes, I think so - haven't disconnected it so I can get the cover off to check

dannyquest
04-30-13, 06:48 PM
dnett, curtc is right about the car eats battery. Same thing happen to my battery. Had it tested & it showed good. The 2nd time the car didn't start, I had to jump start it again. A New battery went in. Went to Walmart got the biggest battery that would fit in the space. Danny

curtc
04-30-13, 06:50 PM
Yes, I think so - haven't disconnected it so I can get the cover off to check

7 years is quite amicable for a battery, typically 5 years is the recommended life.

I'd get a new one IMHO.

Submariner409
04-30-13, 07:21 PM
New battery time - your original has been on borrowed time for 2 years .......... and don't sit with stuff turned on and the engine off - these cars will drain a battery in a heartbeat.

EChas3
04-30-13, 09:50 PM
All good advice above.

The group 101 that's specified is 650 CCA but a Group 78 w/o top posts will usually fit and is 800 CCA or better. I went with the Optima Redtop and we've been happy.

Carvone
05-01-13, 03:26 PM
Went through this last week as I was leaving work. Car went into some kind of 'Theft disable mode' where it wouldn't even allow me to jump it. Finally it timed out and allowed a jump a couple hours later. Had a 101 A/C delco in there that was only 26 months old, they would not stand behind their warranty without the receipt.
Ended up putting a 78 series Duracell in there from Sams, way better battery stats for less than half the cost and fit just fine even with the cover on.

KRSTS
05-01-13, 05:23 PM
Don't buy a DELCO. I prefer the Interstate MTP H6 myself

dnett
05-01-13, 07:07 PM
I was pretty sure I needed a new one, but when the parts store guy said it was OK after testing - I wasn't sure. Bought a new 101 from Advance Auto and put it in today. The old one was the original factory Delco.

EChas3
05-01-13, 07:50 PM
The correct procedure is to test under load. The STS is a demanding application. Most batteries are now made by divisions of Johnson Controls but they are made to different specs. In general, you pay for what you get, whether it's a good battery, a good warranty or both.

We like our Optimas!

carter's_sts
05-04-13, 11:27 AM
I've had parts store guys tell me batteries are good when I know they're not. Even had one guy tell me he could not sell me a battery at all because mine tested ok. Total Idiot. Just took my business elsewhere.

And the other place said it tested bad, which I already knew. I didn't even want their opinions. I just wanted the core credit.

Cadillac Cust Svc
05-04-13, 07:12 PM
Did the new battery resolve the no-start concern you had been having, dnett?
Sarah G. (Assisting Laura)
Cadillac Customer Care