: Service Steering Sys / Stability Secure Mode



Giddy
04-29-13, 08:12 AM
My 2008 AWD started flashing the above during a drive in a rain storm last week. I stopped the car, turned it of and it restarted without the issue. Except that now it has done it a couple of times over the weekend. It comes on and the steering gets heavier. I restart the car and it is steering properly until the warnings come on again.

Any suggestions what it might be?

Thanks,

Giddy.

malatu
04-29-13, 09:09 AM
Had the exact thing happen to my 2006 awd. At first, restarting the car would solve the problem. By the time I got an appointment with dealer, starting the car no longer helped. Long story short, the dealer had to replace a module. They didn't have it in stock so they had to order it. I had a loaner for about a week. The work was performed under GM Extended warranty so I don't know what the cost would have been.

MoistCabbage
04-29-13, 09:44 AM
First step is having the codes pulled.

Giddy
04-29-13, 06:11 PM
First step is having the codes pulled.

It seems I cannot pull my own codes like I can on my 2002??????

Ludacrisvp
04-29-13, 07:19 PM
No built in code reader after 04. (05 Deville I think still has it though)

EChas3
04-29-13, 07:49 PM
Few readers will pull the STS 'body' codes but members report there is one that does, a good value. at Costco. Try some searches or chech the 'Sticky' at the top of the forum.

1BadCadSTS
04-29-13, 08:00 PM
My snap on modus does haha.

dkozloski
04-29-13, 08:44 PM
www.autoenginuity.com (http://www.autoenginuity.com) is an adapter and software for your PC.

Cadillac Cust Svc
05-04-13, 11:48 AM
Any news since your post earlier this week, Giddy? I see that you're writing in from Canada. If you decide to get this checked into by a dealership and feel you need further support, GM of Canada can be reached at 1-888-446-2000 (Hours: M-F 7:30am - 11:30pm, Sat 7:30am - 6:00 EST).

Regards,
Sarah G. (Assisting Laura)
Cadillac Customer Care

Giddy
05-11-13, 11:27 AM
Hi Sarah, Evidently it is an EBCM module that has failed and I am quoted about $2,500 to have it replaced. I am researching alternatives before biting on that quote. Not sure if I can or not though. I will post what I end up doing when its all done unless anyone has any suggestions.

1BadCadSTS
05-11-13, 11:39 AM
Unplug it and put some dialectic grease in the connector. Sounds like water is hitting and shorting it.

Giddy
05-11-13, 05:45 PM
Unplug it and put some dialectic grease in the connector. Sounds like water is hitting and shorting it.

Will try that for sure. Thank you for the suggestion. My mechanic ordered a part in that was incorrect. We have the old one back in the car now and so far it works. We shall see for how long, then try your suggestion.

Cadillac Cust Svc
05-12-13, 04:03 PM
Will try that for sure. Thank you for the suggestion. My mechanic ordered a part in that was incorrect. We have the old one back in the car now and so far it works. We shall see for how long, then try your suggestion.

Hi Giddy,

Good to hear from you. I hope your vehicle stays operating fine without any issues!

Regards,

Laura M.
Cadillac Customer Service

Relate27
05-13-13, 03:09 PM
Hi Giddy I read your post and that exact thing happened to my car last week while I was on the phone with the dealer making an appointment for an oil change. I was driving about 35 and all of a sudden my Stability system kicked on and when it did it felt like someone was hitting the brakes off and on. It lasted for about 15 or 20 seconds and then my traction control light came on. It happened about 3 times that drive all within about 5 minutes time. My check engine light did not come on and that was the first time that had happened to my car. I drive an 07 sts awd , anyway took my car to the dealer the next morning and they could not find anything wrong with my car. there were no codes to pull unfortunately. I wonder if my problem was a bad EBCM module too..

Giddy
05-13-13, 05:11 PM
Hi Giddy I read your post and that exact thing happened to my car last week while I was on the phone with the dealer making an appointment for an oil change. I was driving about 35 and all of a sudden my Stability system kicked on and when it did it felt like someone was hitting the brakes off and on. It lasted for about 15 or 20 seconds and then my traction control light came on. It happened about 3 times that drive all within about 5 minutes time. My check engine light did not come on and that was the first time that had happened to my car. I drive an 07 sts awd , anyway took my car to the dealer the next morning and they could not find anything wrong with my car. there were no codes to pull unfortunately. I wonder if my problem was a bad EBCM module too..

Mine wasn't showing codes either. I had to bring it in when it was alternating between Service Steering Sys / Stability Secure Mode on the readout.

Funny, we put the old one back in and I drove over 300 miles with no issues, then in the rain it came back on again. I stopped and restarted the car after about 30 miles at highway speeds with the warning on. As soon as I restarted the car, no warnings and no warnings since. I am going to drive it a few days to see if it comes back without it raining. My mechanic won't agree with 1BadCadSTS yet though, so we shall see.

Ludacrisvp
05-13-13, 08:18 PM
Hmm in the rain it starts to act up ... sounds like 1badcad is right on the money.

Cadillac Cust Svc
05-15-13, 08:40 PM
Hi Giddy I read your post and that exact thing happened to my car last week while I was on the phone with the dealer making an appointment for an oil change. I was driving about 35 and all of a sudden my Stability system kicked on and when it did it felt like someone was hitting the brakes off and on. It lasted for about 15 or 20 seconds and then my traction control light came on. It happened about 3 times that drive all within about 5 minutes time. My check engine light did not come on and that was the first time that had happened to my car. I drive an 07 sts awd , anyway took my car to the dealer the next morning and they could not find anything wrong with my car. there were no codes to pull unfortunately. I wonder if my problem was a bad EBCM module too..

It's unfortunate that your dealership was unable to duplicate this concern when you went in, Relate27. If it happens again, be sure to take note of any current conditions that may help us to replicate this in the future should you decide to come back in for another round of diagnostics.

Wishing you well,
Sarah
Cadillac Customer Care