: 2009 Onstar not working plus more



Jimmypooh
04-26-13, 01:32 PM
I just bought a 2009 CTS. I'm trying to get voice activation working and it can't hear me at all. I've tracked it down a little but I need some help. The light for onstar is not on at all and none of the buttons work. I assume this is part of the problem since the microphone is part of the onstar system. I've checked the onstar fuse and even replaced it to make sure. I pulled the VCIM out from the glove box and checked to see that it was getting power (Red/White). It is getting power. Now I'm stuck. I don't know where to go from here. I've tried unplugging the mirror and checking the plugs above the roof console, and they all look fine. Is there a switched wire to the unit that I can test?

Any ideas? Thanks in advance!

Jim

jeffc83
04-26-13, 05:59 PM
Unfortunately you literally covered everything that I would mention so I'd recommend taking it back to the dealer unless someone else here has another suggestion for you.

Good luck!

Jimmypooh
04-26-13, 10:50 PM
Thanks for the suggestion. I was hoping to avoid the service fee, but I may not have a choice. I will also need a new key/remote, so that will cost me. Love the car though, and my wife is learning to drive stick on it! She's a little frustrated, but learning well.

Thanks,

Jim

Cadillac Cust Svc
04-28-13, 03:32 PM
Thanks for the suggestion. I was hoping to avoid the service fee, but I may not have a choice. I will also need a new key/remote, so that will cost me. Love the car though, and my wife is learning to drive stick on it! She's a little frustrated, but learning well.

Thanks,

Jim

Hi Jim,

Glad to hear you are loving the car, minus the Onstar issue. Your wife must be excited learning how to drive stick, I know I would be :) Please private message us if you need help locating a dealership or setting up a dealership appointment, or if you have other questions and concerns.

Sincerely,

Laura M.
Cadillac Customer Service

Jimmypooh
05-01-13, 03:53 PM
Any update here in case it helps anyone. They did a bunch of tests and found that the VCIM was getting power but there was not low data output. End result is a new VCIM ($400 plus labor). I did get a 1000 mile 1 month warrany from the dealer I bought it from in MD (Honda dealer), but I'm not sure they will back it since I took it to the local Cadi dealer here.

Quick shout out to great support from Weil Cadillac of Libertyville. They did a lot of tests and answered a lot of questions. I do all the work on my cars if possible and they were happy to help answer questions.

My next work on it will be dealing with the water leak in the trunk. Weil gave me some pointers on how to narrow it down.

thavil
05-01-13, 05:45 PM
Water leak in your trunk is usually from the third brake light. Have them remove the light, put on some new sealant and reinstall the light.

Jimmypooh
05-02-13, 09:17 AM
Thanks for the heads up. I'll do that myself since it's out of warranty and I like working on cars. The right tail light was also loose, so it may have been coming in there. Also, there seems to be a lot of extra weather stripping stuck to the trunk lid. Is that normal or was it a failed attempt to seal water out?