: Cruise Control



cannon1017
04-18-13, 06:27 PM
Yesterday after a stop at a rest stop on the NJ Turnpike, I couldn't set the cruise control on my 2012 SRX. Tried the button located to the left of the set/resume button and got nothing. No icon on the dashboard, nada. Never had a problem with it before. Anyone else having this issue?

TheCaptain
04-19-13, 10:13 AM
There was one other person on here that had that problem, but then we figured out they had actually turned cruise off.
If I remember my buttons right, it sounds like you are trying to turn the main cruise button on and it isn't working. Once you have a few minutes at home, open the battery cover and pull off the negative terminal for 30 seconds. It should reset the whole system. Let us know if it doesn't work beyond this little 'reset'.

njacobsen
04-19-13, 11:14 PM
If you had no icon on the dash, you have likely turned the cruise off. Press the button to the right of the set/resume and the icon should come back on. That button toggles the cruise off/on. When on, the icon on the dash will be white. When cruise is engaged, the icon will be geen. When off, the icon will be gone.

cannon1017
04-19-13, 11:34 PM
njacobson, I tried that and still no icon. I am going to try TheCaptain's fix tomorrow.

cannon1017
04-29-13, 06:20 PM
Captain, I mentioned your fix suggestion to my son and he recommended just unplugging the ECU fuse so that I wouldn't lose my presets and other electronic info. He did that and it worked. Cruise control is working again.

TheCaptain
04-30-13, 10:22 AM
Different path, same result. Good to know it worked!