: 2000 Escalade Brake Light/Turn Signal/Hazard Issue



DiannaHead
04-05-13, 09:13 PM
I am new to forums and could not find exactly my problem described and answered, well here it goes.

Right after I got my Escalade about a month ago I noticed the turn signals and brake lights were not working. I found if i push in my hazard button that the brake lights and turn signals work, but the hazards do not. Now my turn signals still work, but the brake lights either light up just for a split second and then go out, or dont work at all, and this is all 3 the two side brake lights and the one on the top. I checked the fuse inside the cab on the driver side and that is fine. When I looked under the hood at the fuse box there, I see on the diagram on the lit there is a relay labeled brake light relay but there is no relay there, and appears there are no silver parts in the holes like the other relays to even have one put in. and where the stop/brake light #30 big fuse was labeled there was no fuse there. I put a fuse into that spot and still no brake lights. I also noticed that if i have cruise conrol on and if i hit the break it doesnt turn off, i have to actually push the switch off, and nothing shows on the dash that cruise is on. Dont know if that has anything to do with it, or another problem all together. I have read possibly it is the turn signal switch or the brake switch, but those are a big difference in price or maybe it is something totally different wrong. Any help would be great.

the cadillac man
04-05-13, 10:40 PM
I am new to forums and could not find exactly my problem described and answered, well here it goes.

Right after I got my Escalade about a month ago I noticed the turn signals and brake lights were not working. I found if i push in my hazard button that the brake lights and turn signals work, but the hazards do not. Now my turn signals still work, but the brake lights either light up just for a split second and then go out, or dont work at all, and this is all 3 the two side brake lights and the one on the top. I checked the fuse inside the cab on the driver side and that is fine. When I looked under the hood at the fuse box there, I see on the diagram on the lit there is a relay labeled brake light relay but there is no relay there, and appears there are no silver parts in the holes like the other relays to even have one put in. and where the stop/brake light #30 big fuse was labeled there was no fuse there. I put a fuse into that spot and still no brake lights. I also noticed that if i have cruise conrol on and if i hit the break it doesnt turn off, i have to actually push the switch off, and nothing shows on the dash that cruise is on. Dont know if that has anything to do with it, or another problem all together. I have read possibly it is the turn signal switch or the brake switch, but those are a big difference in price or maybe it is something totally different wrong. Any help would be great.

It sounds like the brake light switch is failing as it works both the lights and disables the cruise control at the same time

DiannaHead
04-05-13, 10:48 PM
It sounds like the brake light switch is failing as it works both the lights and disables the cruise control at the same time

Thank you for answering, if I could ask, would that be why I have to have the hazard button down to get anything to work? because that switch could be going out?

the cadillac man
04-05-13, 11:49 PM
Thank you for answering, if I could ask, would that be why I have to have the hazard button down to get anything to work? because that switch could be going out?

It might but I would have to check my wiring diagrams to be sure

bigirb2002
04-08-13, 03:10 AM
you have a bad ground. had it happen on 3 cars. caused all kids of funky stuff. check all body harness grounds

DiannaHead
04-08-13, 09:28 AM
Thank you I will also check for that as well.

2000lac
04-14-13, 07:37 AM
I am new to forums and could not find exactly my problem described and answered, well here it goes.

Right after I got my Escalade about a month ago I noticed the turn signals and brake lights were not working. I found if i push in my hazard button that the brake lights and turn signals work, but the hazards do not. Now my turn signals still work, but the brake lights either light up just for a split second and then go out, or dont work at all, and this is all 3 the two side brake lights and the one on the top. I checked the fuse inside the cab on the driver side and that is fine. When I looked under the hood at the fuse box there, I see on the diagram on the lit there is a relay labeled brake light relay but there is no relay there, and appears there are no silver parts in the holes like the other relays to even have one put in. and where the stop/brake light #30 big fuse was labeled there was no fuse there. I put a fuse into that spot and still no brake lights. I also noticed that if i have cruise conrol on and if i hit the break it doesnt turn off, i have to actually push the switch off, and nothing shows on the dash that cruise is on. Dont know if that has anything to do with it, or another problem all together. I have read possibly it is the turn signal switch or the brake switch, but those are a big difference in price or maybe it is something totally different wrong. Any help would be great.

Did you ever figure out the brake light problem?i have same issue to a T. And alot of times I can't get out of park.

DiannaHead
04-16-13, 02:56 PM
I have not every day i have off it has been raining, we did find if we wiggle or move the brake light switch around they started working again. As soon as i get a chance to do something i will let you know.

DiannaHead
04-28-13, 01:50 PM
Well the turn signal/hazard issue is fixed. I was wrong in how i thought the hazard button worked. I always had turn signals they worked when the button was down the hazard did not when the button was up. I thought button down was hazard on. But to fix that we replaced the flasher relay/fuse/sylenoid. It was called all 3 things by different people. It was just under the dash very easy black cube with prongs. Still trying the brake light switch but it is very hard to get to and remove. Will update more when i can get to it and have it changed.

DiannaHead
04-29-13, 10:09 PM
Finally got the brake lights fixed. It was the brake light switch, the piece that is in the switch to signal the lights was warn out and not pushing down. It was hard to replace the mechanic had to unbolt and move around the steering column. So all problems now fixed thanks so much for the advice it really helped me find the issues and get them fixed.

----------

I also found that i could not get the truck out of park once the brake light switch was replaced it comes out of park perfectly. We did find that we could while the switch was still not working to get out of park reach thru the steering wheel and turn the key to the position just before you start the car then while still holding the key and ignition pull the lever into neutral and start the truck.[COLOR="Silver"]

the cadillac man
04-30-13, 12:17 AM
Finally got the brake lights fixed. It was the brake light switch, the piece that is in the switch to signal the lights was warn out and not pushing down. It was hard to replace the mechanic had to unbolt and move around the steering column. So all problems now fixed thanks so much for the advice it really helped me find the issues and get them fixed.

----------

I also found that i could not get the truck out of park once the brake light switch was replaced it comes out of park perfectly. We did find that we could while the switch was still not working to get out of park reach thru the steering wheel and turn the key to the position just before you start the car then while still holding the key and ignition pull the lever into neutral and start the truck.

The reason it won't let you start the truck is because it is part of the brake/shifter interlock when the brake light switch got worn out it the system didn't know you had the brake on

But it's great you got it fixed(having no brake lights is not fun I know from experience)