: High idle



Caddy Dave
04-02-13, 02:59 PM
I notice that just sometimes, the car idle high when started. When driving like this the car run hot and then the engine light come on. The guy told me the code that comes up is tell me that the car is running to lean or to rich. He also said it could be a vacuum leak some wear or a bad sensor. The question is what should look for to fix this problem, if anyone had this problem as well.

glake89
04-02-13, 04:01 PM
There aren't many vacuum lines to check and at the age of the car, may be brittle. Loose bolts on the intake side of things can allow vacuum leaks. Snug them up.

Caddy Dave
04-03-13, 01:13 PM
Thanks for that. Should I also change the pcv valve and lines? I had replace the spark plugs. It look like the pcv valve is a dealer's part cause i notice these other part stores don't sell it.

glake89
04-03-13, 02:47 PM
Valve is likely OK unless you are getting oil in the air filter box. PVC lines are very suspect for leaks.

08SRX
04-03-13, 04:18 PM
You never stated what high idle is, nor do you say if you have a V6 or V8. Normally, when the V6 starts up it will idle at about 1100 rpm until it warms after which it will idle at about 600 rpm.

Caddy Dave
04-26-13, 03:44 PM
I have the v8 northstar and it idle high off and on after driving stop and go traffic for about a hour. It would go between 1100 and 600 with in the ride. When it do that I also notice that my temp g, move over to the hot side. Now say I pull over and turn off the car to do some thing and get back and start it up I will now hear the front dual fans race to cool it down and stop when the line is back in the middle. I would not hear or feel them come on any other time. I just want to fix this heating problem before is gets worse. What should I do first.

glake89
04-26-13, 04:02 PM
High idle is most likely a small intermittent vacuum leak or a sticking throttle plate. The fans running after re-start is due to heat sink; if you continued driving rather than stopping it would probably cool itself down. I'm not sure you really have a problem other than the idle and that doesn't seem serious yet.