: 2002 Cadillac Escalade sometimes won't start



ms.pat
03-26-13, 01:17 PM
Have had this truck for about a month. Runs great, two owner, well taken care of...This seems like an odd issue but sometimes I put the key in and truck does nothing, security light is on, lights on, radio will come on, no other sounds, no clicking nothing..I thought that my key chain might be interfering with whatever device is in the key and the ignition so I took those off. It worked for a while, now this morning it happened again. It is very cold here and when I realized it would not start after several tries I waited about 10 minutes and put key in again. Truck started right up. I have had the battery, alternator, starter checked-everything fine there. No check engine light. It seems to be something with key?? Also checked with Cadillac dealership service department. They said maybe a sensor/chip issue??? Any suggestions?

MrHolland
03-26-13, 01:57 PM
Moved to proper section.

-----Welcome to the forum!!!

the cadillac man
03-26-13, 03:07 PM
Have had this truck for about a month. Runs great, two owner, well taken care of...This seems like an odd issue but sometimes I put the key in and truck does nothing, security light is on, lights on, radio will come on, no other sounds, no clicking nothing..I thought that my key chain might be interfering with whatever device is in the key and the ignition so I took those off. It worked for a while, now this morning it happened again. It is very cold here and when I realized it would not start after several tries I waited about 10 minutes and put key in again. Truck started right up. I have had the battery, alternator, starter checked-everything fine there. No check engine light. It seems to be something with key?? Also checked with Cadillac dealership service department. They said maybe a sensor/chip issue??? Any suggestions?

It sounds like the starter is failing

djais1801
03-26-13, 07:04 PM
do you have a spare key? if so, try it (to rule out key failure)...maybe years of heavy keychains wore out the ingnition cylinder...had that happen on a previous car of mine

6lbsofSound
03-26-13, 07:49 PM
Ignition cylinder sounds like its the problem.

Black88GTA
03-27-13, 02:48 AM
Have had this truck for about a month. Runs great, two owner, well taken care of...This seems like an odd issue but sometimes I put the key in and truck does nothing, security light is on, lights on, radio will come on, no other sounds, no clicking nothing..I thought that my key chain might be interfering with whatever device is in the key and the ignition so I took those off. It worked for a while, now this morning it happened again. It is very cold here and when I realized it would not start after several tries I waited about 10 minutes and put key in again. Truck started right up. I have had the battery, alternator, starter checked-everything fine there. No check engine light. It seems to be something with key?? Also checked with Cadillac dealership service department. They said maybe a sensor/chip issue??? Any suggestions?

The security light comes on when you try to crank it? When you have the key turned to the start position - does it stay on, or go out? If it's staying on and nothing is happening, it's likely that there is a factory immobilizer (Passlock?) that's acting up.

Pitbull14218
03-31-13, 09:35 PM
Does it crank over or you get nothing when you turn the key?