: 02 Escalade battery light charging issues



Laker_Dynasty
03-24-13, 10:59 PM
Hey guys, I've searched and haven't found an answer yet, so I apologize if I missed it. A couple weeks ago I noticed that in the mornings,,usually 30 degrees or so, the battery light comes on for a few minutes, but after driving a minute or so, the battery gauge goes up from around 11 or 12 volts, up to 14 or so, and the light goes off. One day last week, it did the same thing, only the battery never started to charge and by the time I got to work, the battery gauge was near 2 volts, and nothing in my truck was working,,no gauges, radio, lights, etc. I assumed the Alternator had gone out, so I removed it and had it bench tested at Advance Auto Parts, and they told me it passed the bench test..so I take the battery out, charge it, and have it tested,,,it tests good. With a full charge and the battery and alternator reinstalled I start it up, and the same thing,,,battery light on. I drive to Advance to have them test it on the truck,,they tell me the alternator isn't charging,,(you don't say??? smh), so I proceed to drive home,,after a minute or so of driving, the alternator kicks in and starts charging, battery gauge goes from 12 to 14 volts and does fine. I have since drove it about 8 different times, with the battery light coming on with start up, only to go off and start charging after a minute or 2 of drive time. I have seen posts where people claim the alternator can go out and only charge intermittently,,but I hate to drop 180 dollars if its not the culprit. Anyone else had this issue?? Thanks in advance.

the cadillac man
03-24-13, 11:39 PM
Hey guys, I've searched and haven't found an answer yet, so I apologize if I missed it. A couple weeks ago I noticed that in the mornings,,usually 30 degrees or so, the battery light comes on for a few minutes, but after driving a minute or so, the battery gauge goes up from around 11 or 12 volts, up to 14 or so, and the light goes off. One day last week, it did the same thing, only the battery never started to charge and by the time I got to work, the battery gauge was near 2 volts, and nothing in my truck was working,,no gauges, radio, lights, etc. I assumed the Alternator had gone out, so I removed it and had it bench tested at Advance Auto Parts, and they told me it passed the bench test..so I take the battery out, charge it, and have it tested,,,it tests good. With a full charge and the battery and alternator reinstalled I start it up, and the same thing,,,battery light on. I drive to Advance to have them test it on the truck,,they tell me the alternator isn't charging,,(you don't say??? smh), so I proceed to drive home,,after a minute or so of driving, the alternator kicks in and starts charging, battery gauge goes from 12 to 14 volts and does fine. I have since drove it about 8 different times, with the battery light coming on with start up, only to go off and start charging after a minute or 2 of drive time. I have seen posts where people claim the alternator can go out and only charge intermittently,,but I hate to drop 180 dollars if its not the culprit. Anyone else had this issue?? Thanks in advance.

Before you do anything I would have the charging system checked at a dealer with the tech-2 as it is controlled by the PCM