: 2006 CTS-V wiper relay? Possibly something else.



kschint1@gmail.com
03-19-13, 12:10 AM
My CTS-V is a little crazy. I use the washer fluid then the wipers stay on for an extra long time. Is it the relay or what?

CadillacLuke24
03-19-13, 01:26 AM
Define extra long time.

Submariner409
03-19-13, 08:31 AM
Wrong forum. Moved from the chit-chat Lounge to CTS-V.

CadillacLuke24
03-19-13, 07:28 PM
For my DeVille, when I activate the washer fluid, the washer fluid squirts out the first couple times, and then the wiper blades sweep for another 4-5 passes to clear the widnshield, if not more. Sound like your V at all dude? If that's the case, IMHO I'd say that's normal operation.

AngryHog
03-19-13, 08:19 PM
Been there, done that with my 2006 V. Replace the wiper module. Got mine from Rockauto. Can't recall the price. Maybe $70ish? Was a 5 min swap. My problem started like yours, then got worse. Take care of it sooner rather than later.

If no one else chimes in, I'll see if I can find my email receipt with specifics when I get home in a few hours.

-AngryHog

randomprecision46
05-01-13, 03:17 PM
Been there, done that with my 2006 V. Replace the wiper module. Got mine from Rockauto. Can't recall the price. Maybe $70ish? Was a 5 min swap. My problem started like yours, then got worse. Take care of it sooner rather than later.

If no one else chimes in, I'll see if I can find my email receipt with specifics when I get home in a few hours.

-AngryHog

You have any info on this? Part number or what you bought? All I see are wiper motors etc., nothing called wiper control module on rockauto.com