: Using Katech Short Shifter/ Driveshaft shop driveshaft together; Problems???



Cadillac_Stokes
03-16-13, 07:54 PM
Evening guys.....Ive had my certified GM mechanic install a Katech short shifter & a brand new aluminum Driveshaft from THE DRIVESHAFT SHOP....after the install...i noticed that i cannot go into 3rd gear when driving and seems like something that rotates (thinking something driveshaft related), is rubbing against linkage connected to the shifter when i try to engage. Does anyone know of any issues when using these types mods together at all? :confused: Haven't had a chance to put it on the lift yet to see whats going on cause it was done yesterday....wont be able to till Monday. Just wondering what i could look for if anybody has experience with this.....I appreciate the response from you all.....

rand49er
03-17-13, 11:38 AM
PISNUOFF or Fuzzylogic might be able to put their finger on this. This'll serve as a:bump:.

PISNUOFF
03-17-13, 01:38 PM
Sounds like the bottom of the center shift linkage is hitting the driveshaft. It makes sense that it does it in third gear as that is centered laterally and the furthest rearward. The first thing to check is the orientation on the pivot cup housing. It is the two-piece nylon assembly inside the console. If you orient the 'relief' towards the bottom of the car it will raise the shifter about 3/16". I suppose you could also shim down the trans crossmember which would lower the trans and driveshaft. That would be my last resort.

If that doesn't help, I can make you a shifter that is a little shorter under the pivot and won't hit.

FoD
03-17-13, 02:08 PM
^ This. I have a shifter from PISNUOFF and a 3.5" driveshaft...zero rubbing issues.

Cadillac_Stokes
03-17-13, 05:18 PM
Thanks guys.....You guys just don't know how ANXIOUS i am to really drive this car after replacing Motor mounts,Tranny mount, Diff mount, Clutch, Flywheel AND Driveshaft....all at once! :stirpot: Cha-Ching! $$$ Gonna see tomorrow if my mechanic would be willing to try the shim the crossmember.....or grind the bottom the shifter or something........if it doesn't work or he's not willing to do....PISNUOFF get ready to make a couple of dollars! CANNOT go back to the factory shifter! #OhHellNO!

shadybx7
03-17-13, 05:25 PM
i have CS MM, stock trans mount and katech SS. DSS 2 piece DS and no rubbing no problems

Cadillac_Stokes
03-17-13, 10:43 PM
I have a one piece shaft.....i guess thats the difference.... Is there anything better about having a two piece-vs- a 1 piece setup?

verywhitedevil
03-18-13, 10:50 AM
i have a katech STS and 1 piece with CS tranny mount. had to install 2 washers on the tranny crossbrace for clearance.

working with katech now. removing .15 of bottom. should do the trick.

Cadillac_Stokes
03-18-13, 12:09 PM
i have a katech STS and 1 piece with CS tranny mount. had to install 2 washers on the tranny crossbrace for clearance.

working with katech now. removing .15 of bottom. should do the trick.

Going to see about this in an hr or so...Hope he doesn't wanna do everything "by the Book"...thanks a lot Devil!