: Audio system problems?



Stewie2395
03-14-13, 05:30 PM
Okay I have a 2001 Cadillac Catera. i'm installing a new HU.

The problem is that after I have it installed and hooked up it blows fuses, I've already been through a 10amp (which it is suppose to use), a 20 amp and 30 amp fuse..

Does anyone have an idea why it is doing this?

CadillacManny
03-14-13, 06:33 PM
How hard is it to get the front door panels off to replace front speakers

Stewie2395
03-14-13, 06:41 PM
why would i need to do that?

CadillacManny
03-14-13, 07:20 PM
No I just wanna no

JohnJJO
03-14-13, 11:27 PM
Look at my video. Type " catera door noise" on youtube

MoistCabbage
03-15-13, 04:00 PM
Okay I have a 2001 Cadillac Catera. i'm installing a new HU.

The problem is that after I have it installed and hooked up it blows fuses, I've already been through a 10amp (which it is suppose to use), a 20 amp and 30 amp fuse..

Does anyone have an idea why it is doing this?

Is this a replacement stock HU, or after market?

Either way DO NOT USE LARGER FUSES. The whole point of a fuse is to protect the wiring from higher amperage than it's rated for. Using a higher amperage fuse, defeats the purpose. You'll end up with a larger problem.

Stewie2395
03-15-13, 08:11 PM
Its an aftermarket ... and yea.. so what now?

MoistCabbage
03-15-13, 09:37 PM
When is it blowing the fuse? As soon as it's plugged in? When it's turned on? While it's on?

Stewie2395
03-15-13, 10:21 PM
no, i put a fuse in, when i turn the key to the on position thats when it blows

MoistCabbage
03-16-13, 12:25 AM
Are you sure the harness was wired correctly?

Stewie2395
03-16-13, 08:54 PM
I'm pretty sure I read the instructions very carefully... and even with everything unplugged for the car harness, it still pops.