: Heated seat not working



PearlWhiteSTS
03-11-13, 07:07 PM
I noticed this weekend that the passenger side heated seat has a problem. When turned on, the indicator lights come on but only stay on for 30 second or so and then go out. The seat does not seem to heat at all. I will have it looked out when in for an oil change on the 29th, just wondering if anyone else has had this problem or has any suggestions/comments.

TheCaptain
03-11-13, 07:51 PM
Yep, my 2010 would do it once in a blue moon. Disconnect a battery terminal (+ or -) and reconnect after 30 seconds. That might fix it. If not, then somethings broken.

stevec5375
03-11-13, 08:00 PM
Yet another duplicate thread. Why not close it too? Maybe I need to do the documented Google search to prove my point?

cadigirlchicago2
03-11-13, 10:07 PM
Mine did the same thing, the light would come on, and then click off less than 30 seconds later. There was something faulty that got replaced while I still had warranty coverage. I'd take it in.

TheCaptain
03-12-13, 07:22 AM
Yet another duplicate thread. Why not close it too? Maybe I need to do the documented Google search to prove my point?
I can always use a hand!

Marc NY
03-12-13, 11:53 AM
Yet another duplicate thread. Why not close it too? Maybe I need to do the documented Google search to prove my point?Steve lets be truthful, you and I both know that these type of threads are mostly started by new members who unfortunately haven't read all the previous threads and posts to get enough information to help them out.

On the other hand YOU ... have been here for a very long time and know better than to keep posting previous topic threads over and over again. There is a big difference between you and newbie who only has a few posts! :stirpot:

Cadillac Cust Svc
03-12-13, 12:00 PM
PearlWhiteSTS, I hope you'll keep us updated after you bring it to your dealer's attention! If you ever have questions or additional concerns in the meantime, I'm just an email away at Katie_Lucille@gmexpert.com.

Best,

Katie
Cadillac Customer Service

Kauai 1
03-12-13, 06:33 PM
PearlWhiteSTS, ours did exactly the same thing the first time we tried the heated passenger seat. Took it to the dealer for a warranty repair; a short was found on the driver's side. Fixed under warranty, and now works well.

lenashley
12-17-13, 03:48 PM
my heated seats didn't work, tool it in and they replaced the heated seat control module, now the back heats up but not the seat, what's going on

Cadillac Cust Svc
12-19-13, 01:32 PM
my heated seats didn't work, tool it in and they replaced the heated seat control module, now the back heats up but not the seat, what's going on
Hello lenashley,

I am sorry to hear that your heated seats aren’t working after they replaced your heated seat control module. Did you have this done at a Cadillac dealership, and have you brought this to their attention that your vehicle still isn’t operating as it should?

Gregory W.
Cadillac Customer Care

'12CTSman
12-20-13, 03:13 PM
Yet another duplicate thread. Why not close it too? Maybe I need to do the documented Google search to prove my point?
Huh?

TheCaptain
12-21-13, 09:42 AM
That was from early in the year when I closed a thread of Steve's that duplicated another, yet left this one open. (For reasons I can't remember) :hmm: