: Engine hot ac off



gruvent
03-09-13, 11:45 AM
Engine hot ac off error message on DIC. Comes up as soon as the car starts ( even if the car is cold). Temperature gauge reads nothing, and digital temperature reads - - -

From what I read on here it could be:
1) thermostat 2) sending unit 3) reset computer.
Where should I start?

darkman
03-09-13, 11:52 AM
Engine hot ac off error message on DIC. Comes up as soon as the car starts ( even if the car is cold). Temperature gauge reads nothing, and digital temperature reads - - -

From what I read on here it could be:
1) thermostat 2) sending unit 3) reset computer.
Where should I start?

3-2-1

Resetting the computer is free - disconnect battery for 30 minutes.

Sending unit is the most likely - they don't cost much. GM Part Number 15326388

Thermostat is unlikely since it is not in play when you start the car.

It also could be oxidation on Ground 101, or other grounds in the engine compartment - see attached.

gruvent
03-09-13, 12:10 PM
Thanks darkman, that makes sense. By chance do you know where the sending unit is on the LS2? (2006)

darkman
03-09-13, 12:18 PM
Thanks darkman, that makes sense. By chance do you know where the sending unit is on the LS2? (2006)

I don't know with certainty. I assume that it is located on the driver's side cylinder head at the front. The LS2 and the LS6 have the same cylinder heads.

Supplement: Rock Auto shows the part number for the LS2 and LS6.

pato
03-10-13, 12:06 AM
^^ That is correct. The coolant sensor is next to the exhaust port for cylinder 1 (driver's side head).

gruvent
03-15-13, 01:07 AM
For the record, The Computer reset did not work, came back on shortly after the reset.

However,I did unplug the sensor wire (at the sensor) and plugged it back it and the problem went away. So it's possible that the contacts just need to be cleaned.

Thanks!