: 2006 DTS front turn signals, fog lamps, high beams, cornering lights out!



Austijohn
03-03-13, 08:54 AM
I have a 2006 DTS that currently has both front turn signals, both front cornering lamps, both fog lamps, and both high beams out. The low beams, rear and side mirror turn signals, and running lights still work fine. All of the lights on the dash (fog and high beam) display properly with the exception of the rapid turn signal flash. It appears that all of the bulbs are good, and I couldn't locate a bad fuse in either the front or rear fuse block. Do all of these items share a common ground?? If so, where is it located? Any help would be greatly appreciated!

grullon10
03-04-13, 08:03 AM
it could be the front fuse box. Try to remove it it has 2 bolt loose them and try to remove. water get into it and it goes bad. try to clean the plug that connect to the box. Also take a look with a flash light in to the box if you see white rust that mean is going bad. These fuse boxes get oxideze because of water I had something similar my cooling fans stop working at low speed change relay change fuse did not work until find out that it was the front fuse box.

Austijohn
03-04-13, 10:16 AM
Sounds good. I'll take a look at it later today and report back with my findings. Thanks for the response!

Austijohn
03-05-13, 06:20 PM
It turned out that one of the three the wiring harnesses under the fuse box had come loose. It was the one closest to the windshield. I tightened the bolt on the top side of the fuse box and I was good to go! Good call on the fuse box. Thanks for your help narrowing it down!

grullon10
03-05-13, 06:49 PM
That's why we are here for