: 88 fleetwood engine randomly dies



doobbdoob
02-28-13, 02:44 AM
My 88 fleetwood has been very reliable untill about 2 weeks ago. It has been leaving me stranded! The engine will just quit running. When i try to restart, it cranks and cranks but there's no fire in the hole. Hours later i return to my abandend fleetwood with intensions to tow it home and it starts right up like nothing ever happened. Any suggestions?

BigCadMan_1
03-07-13, 08:18 PM
Sounds like a bad fuel pump.

brougham
03-11-13, 09:33 PM
Pull the trouble codes.
Bad cam sensor or pickup in the distributor is a common cause of that problem but it can also be another failing electronic part that has become heat sensitive.

drewsdeville
03-12-13, 10:13 PM
Intermittent problems can be difficult. Unfortunately, to diagnose, you'll have to wait for it to fail again. Next time it won't start, check for fuel and spark. It's not getting at least one of the two. That will guide you to the next step.

doobbdoob
03-19-13, 05:46 AM
All the feed back helps, thanks. Still tryin to pinpiont the problem. Where can i get trouble code definitions?
The last time the engine died i checked for fuel and spark. Had fuel pressure at shreader valve fuel rail, but no fuel coming out the injectors. No spark either.

BigCadMan_1
03-29-13, 12:58 AM
All the feed back helps, thanks. Still tryin to pinpiont the problem. Where can i get trouble code definitions?
The last time the engine died i checked for fuel and spark. Had fuel pressure at shreader valve fuel rail, but no fuel coming out the injectors. No spark either.

Here: http://www.cadillacforums.com/forums/ht4100-4-1-4-5-4/21558-obd-i-codes-4-x-engines.html

creeker
03-29-13, 01:10 AM
All the feed back helps, thanks. Still tryin to pinpiont the problem. Where can i get trouble code definitions?
The last time the engine died i checked for fuel and spark. Had fuel pressure at shreader valve fuel rail, but no fuel coming out the injectors. No spark either.

How much pressure did you have?, should be around 40 psi I think

drewsdeville
03-29-13, 10:09 PM
Had fuel pressure at shreader valve fuel rail, but no fuel coming out the injectors. No spark either.may be a problem with the ignition control module. How do you know there was no fuel from the injectors?

doobbdoob
03-31-13, 09:38 AM
Its throttle body injected. I removed the air horn and while cranking I should have seen a cone shaped mist of fuel from the injectors. Lots of pressure at inspection valve.

drewsdeville
03-31-13, 10:38 PM
Ah yes... I wasn't paying attention and thought this was a multiport engine. Still, it may be an ignition module problem. It may be worth having it tested.

brougham
04-02-13, 06:08 AM
The pickup and ignition/HEI module both control the injectors, or at least signal the computer when to pulse them. So a problem with either will cause that kind of problem and HEI modules do go bad.

doobbdoob
04-07-13, 02:00 PM
The codes Im getting are E-12, (no distibutor signal) and E-52, (data factory reset) Im going to go ahead and replace the ignition pickup coil inside the distributor.

doobbdoob
05-12-13, 01:09 AM
Well... I replaced the coil and ingnition modual. But it still randomly dies. Any other ideas? Still getting the same codes.

cadillac_al
05-13-13, 07:54 PM
It's most likely the hall effect switch. If you check all the E12 threads around here you will see how others fix it and see why some opt to just buy a rebuilt distributor for $150ish.