: Oil Gauge



EscaladeLady
02-26-13, 01:53 PM
I have a 2003 Escalade. The oil pressure gauge is reading 80. It runs great nothing seems to be wrong. Is it maybe the sensor?

the cadillac man
02-26-13, 07:22 PM
I have a 2003 Escalade. The oil pressure gauge is reading 80. It runs great nothing seems to be wrong. Is it maybe the sensor?

Does the gauge drop down to 0 when the key is off or does it peg in one spot

If the first one then the sender may be bad if its the later one then the stepper motor is failing

bstrang6
02-27-13, 11:10 AM
I have the same issue but my needle does move. Where is the sender located at?

wesyder
02-27-13, 12:55 PM
I have the same issue but my needle does move. Where is the sender located at?

Top center rear of the engine block between the intake manifold and the firewall... kind of a pain

RippyPartsDept
02-27-13, 01:40 PM
clusters on 2003-2005 trucks and suvs have had lots of problems (mostly with the spedo) in recent years
so much so that there was a special coverage warranty extension for many of them
if it doesn't turn out to be the sensor it could be the cluster and you should have your dealer check your VIN to see if you're included in the special coverage

the cadillac man
02-27-13, 02:01 PM
clusters on 2003-2005 trucks and suvs have had lots of problems (mostly with the spedo) in recent years
so much so that there was a special coverage warranty extension for many of them
if it doesn't turn out to be the sensor it could be the cluster and you should have your dealer check your VIN to see if you're included in the special coverage

Rippy mine was replaced under that before I got my truck which I was glad I didn't have to worry about it going nuts on me at some point in time after I got(getting the service history is a great thing when buying a used vehicle)

RippyPartsDept
02-27-13, 04:51 PM
ok then it's probably related to the sensor then

the cadillac man
02-27-13, 11:07 PM
ok then it's probably related to the sensor then

I ain't the op I was just saying that mine had been replaced under the extension before I got the truck(I found out by getting the service history from my local dealer)
I prefer the one where the numbers on the speedo follow the chrome ring over the one that's in my truck though

RippyPartsDept
02-27-13, 11:53 PM
whoops...

the cadillac man
02-28-13, 02:46 AM
whoops...

Don't worry about it happens to me from time to time

djais1801
02-28-13, 11:32 AM
clusters on 2003-2005 trucks and suvs have had lots of problems (mostly with the spedo) in recent years
so much so that there was a special coverage warranty extension for many of them
if it doesn't turn out to be the sensor it could be the cluster and you should have your dealer check your VIN to see if you're included in the special coverage
i looked into it, the vehicle must have between 71-80,000 miles.

RippyPartsDept
02-28-13, 11:48 AM
yeah there is a mileage limit (no lower limit, but definitely an upper limit... 80 sounds a bit low but could be correct)

djais1801
02-28-13, 11:51 AM
see link for coverage....
http://www.gaugepegged.com/gm-recall.html

RippyPartsDept
02-28-13, 01:10 PM
yup 80k is the limit ... i guess they're giving you 30k extra on the warranty mileage (for cadillac... more for chevy and gmc)

EscaladeLady
02-28-13, 08:52 PM
Yeah when motor is turned off oil gauge goes back to 0.

the cadillac man
02-28-13, 10:31 PM
Yeah when motor is turned off oil gauge goes back to 0.

Then it's the sender