: p0411 incorrect air flow



grullon10
02-21-13, 08:39 PM
Like I said before I had spend a lot of money trying to correct this problem. I posting this is because I'm to spend another 200 to 500 bucks by changing the exhaust manifold. Any ideal.

Superjim
02-21-13, 08:41 PM
I don't know what is causing it, but I have very serious doubts it is the exhaust manifold...

grullon10
02-21-13, 10:57 PM
Doing that is one of the last thing I could to fix it. I have follow every step that gm reconmend to do we even reprogram the ecm. The next 3 steps are change the intake and right side exhuast manifold or change the engine. That exhuast manifold on the top it has a track the fresh air gos into the motor when the pump is on. On the last test that I did we compare my 06 dts with an 08 the only different was with the pump off the baro pressure and the air presure were the same with the pump on my 06dts the air pressure when up 25psi but on the 08 only when up 15psi.

danog
02-22-13, 12:20 AM
I hope you are doing this on a cold start. You answered your own question. The pressure is too high. Take of the control valve off and command it on and see if it opens up all the way. It sounds like the valve is not opening all the way. Swap the vale off the 08 for a few days.


During phase 1, both the AIR pump and the solenoid valve are activated. Normal secondary air function occurs. Expected system pressure is 815 kPa above BARO

The ECM determines that the difference between the predicted system pressure and the actual system pressure is greater than 5 kPa
OR
The ECM determines that the difference between the predicted system pressure and the actual system pressure is less than −5 kPa.

DTC P0411 sets during phase 1 and within 22 seconds when the above conditions are met.

grullon10
02-22-13, 02:35 AM
It is a new valve I change it 2 month ago, thinking that was the problem and it was not.

grullon10
03-12-13, 07:55 AM
Update nothing new it is going to cost me a lot of money to fits the problem it is a clog headvalve. If any of you have taken of one of the valvehead at the exhaust outlet they 4 small channel that bring the air from the check valve in to the motor they get plug with carbon and the only way to clean it is by removing the right side head. 06 and newer they only have one check valve the one by the fire wall. Later today I'm going to pst some pic.

grullon10
03-17-13, 06:08 PM
Finally fits it by removing the exhaust manifold agaist the fire wall and inside the head there are 4 holes that bringe the fresh air in to the exhaust system they get clog. To clean it you have to use a small flat head screwdrive and cab cleanner is not easy.

Tom's Caddy
03-18-13, 09:12 AM
Did this finally fix you're problem, if so Great news. Way to stay with it and not give up.:thumbsup:

grullon10
03-18-13, 11:53 AM
Tom I had to now I don't have the money to get another one.

BIGDADDYCADDY07
03-18-13, 11:35 PM
NICE WORK JOB WELL DONE :bouncy::bouncy::bouncy::cool2: