: Aux input on a base Deville with no tape



KyZiX
02-19-13, 12:38 PM
I'm hoping for some best options from you all on how to get an auxiliary input installed for my base Deville. I've seen the Auxiliary Input on Seville/Deville/Catera: DIRECT connection (http://www.cadillacforums.com/forums/cadillac-audio-video-security-systems/108708-auxiliary-input-seville-deville-catera-direct.html) from N*Caddy (http://www.cadillacforums.com/forums/member.php?u=47596) and the "Bose" related thread as well. I have also found on Google searches articles and write-ups on how to wire in an aux jack directly into the tape inputs inside the radio.
My issues are that...
my radio does not match that of N*Caddy (http://www.cadillacforums.com/forums/member.php?u=47596)'s article.
my unit does not have a tape player, so I cannot use a cassette adapter (not that I would want to.)
I will NOT replace my HU with an aftermarket (I have researched and it seems an upgrade to better stock unit isn't really an option either right?)
I want to keep steering wheel controls. I travel alot, and I need the ability to play music from my phone which will also give me (in a sense) handsfree calling which is really just speaker phone through the cars radio.
Here is my HU. Any and all help is appreciated.
Interestingly, after snapping these pics, when I placed the HU back into the car and turned the key to ON the radio displayed some sort of "Tape" text with the UP arrow?!?!?!
FRONT
http://www.flsbk.com/images/cadi/radio_front.jpg
INSIDE
http://www.flsbk.com/images/cadi/radio_inside.jpg
BACK
http://www.flsbk.com/images/cadi/radio_back.jpg

N*Caddy
02-21-13, 09:34 AM
Well, this is the one unit I have never looked at.
Although is different is pretty similar (is Spanish "es mismo pero no igual").
http://img703.imageshack.us/img703/8598/tmpec.jpg
I took the liberty of modifying your picture (hope you don't mind) and highlighted yellow the two small connector I believe are the CD player connectors probably one of the 2 (the 3 pin one?) is the audio signal.
The chip in the middle of the motherboard seems to be the AUDIO processor. That is the chip where all the audio stuff happens (volume control, EQ, Balance, Fade, Source selection). I would like to know exactly what is written on that chip (should be the P# and the manufacturer).
Then note on the right side (of the picture) I highlighted baby blue the amplifier. In the back of the HU the chip mounted on the case is the final stage amplifier. From that chip you will see connections going straight to 8 pins in the 32 male (blue) connector (that is your speaker signal).
Then on the left side (of the picture) in that metal case is the radio board. The radio board should have many connections to the motherboard, 2 of these going (possibly with some components in between) to the chip in the middle (I suspect as being the audio processor).
If you can provide me with the numbers on the central chip I may find its diagram and figure out what it does and how can a AUX input be hooked up. You should have audio signal going between this chip and the amplifier board but you can't tap into that because it is past the volume control and all other audio settings.
Alternatively you can replace the HU with a BASE HU with TAPE/Radio but no CD. I know exactly what to do on that one but you do lose the in Dash CD and your only option would be CD changer.

KyZiX
02-22-13, 10:59 AM
Awesome, thank you N*Caddy.
Below is a better pic of the chip in question. You say the set of two connectors (you highlighted in yellow) are possibly for CD player. Do you mean Tape Player?
I'm confident in my soldering skills, even direct on the PCB so no problem there. I see from your aux input thread (http://www.cadillacforums.com/forums/cadillac-audio-video-security-systems/108708-auxiliary-input-seville-deville-catera-direct.html) what I may need to do here if that is the best option, however I am wondering how difficult it may be to fool the radio into thinking I have inserted a tape when I plug in my phono jack? What do you think?
There is no way to swap in a HU with TAPE and CD? Not that I would really feel bad about losing either one really, as long as I can get an input.

The Chip in the middle is labeled as follows:
http://www.flsbk.com/images/caddi/radio_chip_closeup.jpg
N60 MASK
12219555
0337KEA01
23194R
I also included the picture as I explained showing "Tape". Steps to reproduce. With ignition OFF. Power off HU, remove from dash and unplug connector. Reconnect plug and turn ignition to ON, power on HU.
http://www.flsbk.com/images/caddi/tape_play.jpg

KyZiX
02-26-13, 09:29 AM
Update: I am going to visit with a local small electronics shop to find some connectors and wires to bring direct connection to these ports outside of the HU to test. I will be using the "tape play ^" via re-install bug of the HU to search for a audio signal connection, then I will be searching for what triggers the tape function. I have found that the "RW FF" buttons (for CD) try to function properly in TAPE mode by allowing the radio signal to bypass the tape signal while in use.

Here is a call out to any owners of similar radio models with tape. I'd really appreciate any help if you can reference connection on the inside of your HU to match up to what is missing on mine.

KyZiX
03-05-13, 11:10 AM
Sadly my efforts have been met with the oddest experience with electronics. I used a computer CD-Rom audio wire to extend the leads from the pictured unused connector (the three prong, hoping it would be simply left, right and common) to the outside of the radio in an effort to find audio input. Somehow, and I dare someone to explain this, the HU knows the wires are connected and the system went wacky. HU display blanked out, door locks tripped a few times and the instrument panel read something about service security something or rather. Now I can no longer recreate the TAPE ^.
Unfortunately this only leads me to now having to research for the optimal aftermarket HU installation. Any other suggestions for aux input is welcomed.

txtaz
03-05-13, 06:37 PM
I'm curious now.
Did you only plug in the connector (cd-Rom) with the leads not conneted to anything (just open) or did you attempt to attach rca's or direct low level audio wires?
I ask becasue I have seen board stress (physical) do funny things in computers.
Taz

KyZiX
03-07-13, 09:29 AM
The leads were open. I never got to the point where I could input a signal. My connections were nearly perfect of a fit also. Very curious indeed. I am all over the web now trying to figure out a possible next step.

txtaz
03-09-13, 08:22 AM
Did everything return to normal after removing the plug?
Also, did you ground yourself to the radio chassis and then a drain wire while working on it? Use anti static mat?
You might have fried a chip with your body's static.
Hope this helps.
Taz

N*Caddy
03-09-13, 11:50 AM
I can't find the chip diagram but you can always install a '96-'97 Base HU. You can add the AUX input easily on that one and it has no TheftLock to worry about. You can also install a '98-'01 base HU, is identical except it has the Theftlock feature so you need the TechII to clear the VIN. Going this way you loose the InDash CD. You get the Tape (not relevant) but you can always use the CD Changer.